summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorJukka Rissanen <jukka.rissanen@linux.intel.com>2014-07-21 12:59:09 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-23 20:59:13 (GMT)
commit6ac058cffe163a871eb0fe24351e421d8530bd2c (patch)
tree93f7402ebb8cd191c88b657b1416640c631ad8a2 /meta/recipes-connectivity
parent56bfda20f4d38373395b455d1e4b79b46d111a20 (diff)
downloadpoky-6ac058cffe163a871eb0fe24351e421d8530bd2c.tar.gz
connman: Fix PPTP VPN plugin QA issue
This error was seen when building ConnMan. Fixed by not building ConnMan pptp plugin with module versioning info. ERROR: QA Issue: non -dev/-dbg/-nativesdk package contains symlink .so: connman-plugin-vpn-pptp path '/work/core2-32-oe-linux/connman/1.24+gitAUTOINC+42779cd63c-r20/packages-split/connman-plugin-vpn-pptp/usr/lib/connman/scripts/libppp-plugin.so' [dev-so] ERROR: QA run found fatal errors. Please consider fixing them. ERROR: Function failed: do_package_qa (From OE-Core rev: d2328d6aa52fd4f0b47ae3292ae6ae07301bf9d0) Signed-off-by: Jukka Rissanen <jukka.rissanen@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/connman/connman/build-libppp-plugin-without-versioning-info.patch32
-rw-r--r--meta/recipes-connectivity/connman/connman_1.24.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/connman/connman/build-libppp-plugin-without-versioning-info.patch b/meta/recipes-connectivity/connman/connman/build-libppp-plugin-without-versioning-info.patch
new file mode 100644
index 0000000..8e81f1b
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman/build-libppp-plugin-without-versioning-info.patch
@@ -0,0 +1,32 @@
1Upstream-Status: Submitted
2Signed-off-by: Jukka Rissanen <jukka.rissanen@linux.intel.com>
3
4From dd8044ed6ccb468558bab037257e27a409903d86 Mon Sep 17 00:00:00 2001
5From: Jukka Rissanen <jukka.rissanen@linux.intel.com>
6Date: Mon, 21 Jul 2014 15:01:45 +0300
7Subject: [PATCH] scripts: Build libppp-plugin as a plain .so file
8
9There is no need to have module versioning for libppp-plugin.so
10file so build the plugin same way as other vpn plugins.
11
12This issue was seen when building ConnMan for Yocto.
13---
14 Makefile.plugins | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/Makefile.plugins b/Makefile.plugins
18index 294cae0..8139967 100644
19--- a/Makefile.plugins
20+++ b/Makefile.plugins
21@@ -4,7 +4,7 @@ plugin_cflags = -fvisibility=hidden -I$(srcdir)/gdbus \
22 plugin_ldflags = -no-undefined -module -avoid-version
23
24 script_cflags = -fvisibility=hidden -I$(srcdir)/gdbus \
25- @DBUS_CFLAGS@
26+ @DBUS_CFLAGS@ $(plugin_ldflags) -shared
27
28 if LOOPBACK
29 builtin_modules += loopback
30--
311.8.3.1
32
diff --git a/meta/recipes-connectivity/connman/connman_1.24.bb b/meta/recipes-connectivity/connman/connman_1.24.bb
index 66a8c58..29e239c 100644
--- a/meta/recipes-connectivity/connman/connman_1.24.bb
+++ b/meta/recipes-connectivity/connman/connman_1.24.bb
@@ -4,6 +4,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/network/${BPN}/${BP}.tar.xz \
4 file://0001-plugin.h-Change-visibility-to-default-for-debug-symb.patch \ 4 file://0001-plugin.h-Change-visibility-to-default-for-debug-symb.patch \
5 file://add_xuser_dbus_permission.patch \ 5 file://add_xuser_dbus_permission.patch \
6 file://connman \ 6 file://connman \
7 file://build-libppp-plugin-without-versioning-info.patch \
7 " 8 "
8SRC_URI[md5sum] = "dd6e1b4d9b9a28d127edb9f9b58bdec1" 9SRC_URI[md5sum] = "dd6e1b4d9b9a28d127edb9f9b58bdec1"
9SRC_URI[sha256sum] = "551df7a5f0c6e4d69523dd2b3aa2c54525b323457d5135f64816215bad3dc24c" 10SRC_URI[sha256sum] = "551df7a5f0c6e4d69523dd2b3aa2c54525b323457d5135f64816215bad3dc24c"