summaryrefslogtreecommitdiffstats
path: root/meta-yocto/conf
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-06-28 15:12:22 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-28 15:29:29 (GMT)
commitc1df5188bb2851bcc5a3f483b0a0b4c4f884e3c7 (patch)
treee8da46b5e3642d6da83a7102930c2c3ffd3dd83e /meta-yocto/conf
parent48cb1816c86115a25f2230ecdbe08b1ea9133b40 (diff)
downloadpoky-c1df5188bb2851bcc5a3f483b0a0b4c4f884e3c7.tar.gz
poky.conf: fix WARN_QA and ERROR_QA settings
In OE-Core master revision 8f5675e6d3eb the bug that tests we did not mention in ERROR_QA were being shown as warnings even if they weren't in WARN_QA was fixed; however a number of warnings we want to be enabled weren't in Poky's WARN_QA and thus were not shown after that change; additionally some of these were set in the default value of ERROR_QA in insane.bbclass (i.e. OE-Core's default) but would have previously shown up as warnings in Poky because they weren't in ERROR_QA there. To fix this, put the appropriate values back into WARN_QA / ERROR_QA with a lean towards ERROR_QA - we want to be strict so that we keep OE-Core clean of QA issues during recipe maintenance. Fixes [YOCTO #4752]. (From meta-yocto rev: 01886121ef4740e35f24ac9a6d851cefd6d750fd) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-yocto/conf')
-rw-r--r--meta-yocto/conf/distro/poky.conf10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta-yocto/conf/distro/poky.conf b/meta-yocto/conf/distro/poky.conf
index 0968a0c..14919f2 100644
--- a/meta-yocto/conf/distro/poky.conf
+++ b/meta-yocto/conf/distro/poky.conf
@@ -99,8 +99,12 @@ OELAYOUT_ABI = "8"
99# add poky sanity bbclass 99# add poky sanity bbclass
100INHERIT += "poky-sanity" 100INHERIT += "poky-sanity"
101 101
102#WARN_QA = "unsafe-references-in-binaries unsafe-references-in-scripts" 102# QA check settings - a little stricter than the OE-Core defaults
103WARN_QA = "textrel pkgvarcheck" 103WARN_QA = "textrel files-invalid incompatible-license xorg-driver-abi"
104ERROR_QA = "dev-so debug-deps dev-deps debug-files arch pkgconfig la perms useless-rpaths rpaths staticdev ldflags" 104ERROR_QA = "dev-so debug-deps dev-deps debug-files arch pkgconfig la perms \
105 useless-rpaths rpaths staticdev ldflags pkgvarcheck already-stripped \
106 compile-host-path dep-cmp installed-vs-shipped install-host-path \
107 libdir packages-list perm-config perm-line perm-link pkgv-undefined \
108 pn-overrides split-strip var-undefined"
105 109
106include conf/distro/include/seperatebuilddir.inc 110include conf/distro/include/seperatebuilddir.inc