summaryrefslogtreecommitdiffstats
path: root/meta-emenlow
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-07-22 14:26:48 (GMT)
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-22 14:26:48 (GMT)
commitc9602c5feb9a2694446363e978e75ad716008b5d (patch)
tree0675b803d9a0975f085200548695d73611d92a49 /meta-emenlow
parente35762d97118d393bf1461e376b6d3d436245179 (diff)
downloadpoky-c9602c5feb9a2694446363e978e75ad716008b5d.tar.gz
emenlow: Set COMPATIBLE_MACHINE where needed
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-emenlow')
-rw-r--r--meta-emenlow/packages/libva/libva_0.31.0.bb3
-rw-r--r--meta-emenlow/packages/psb-firmware/psb-firmware_0.30.bb2
-rw-r--r--meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb2
-rw-r--r--meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb2
-rw-r--r--meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb2
-rw-r--r--meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb2
6 files changed, 13 insertions, 0 deletions
diff --git a/meta-emenlow/packages/libva/libva_0.31.0.bb b/meta-emenlow/packages/libva/libva_0.31.0.bb
index 52cd599..bd9f758 100644
--- a/meta-emenlow/packages/libva/libva_0.31.0.bb
+++ b/meta-emenlow/packages/libva/libva_0.31.0.bb
@@ -33,3 +33,6 @@ export LDFLAGS="-Wl,-z,defs"
33EXTRA_OECONF = "--disable-i965-driver" 33EXTRA_OECONF = "--disable-i965-driver"
34 34
35FILES_${PN} += "${libdir}/va/drivers/*" 35FILES_${PN} += "${libdir}/va/drivers/*"
36
37COMAPTIBLE_MACHINE = "emenlow"
38PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-emenlow/packages/psb-firmware/psb-firmware_0.30.bb b/meta-emenlow/packages/psb-firmware/psb-firmware_0.30.bb
index 0a41173..164ea66 100644
--- a/meta-emenlow/packages/psb-firmware/psb-firmware_0.30.bb
+++ b/meta-emenlow/packages/psb-firmware/psb-firmware_0.30.bb
@@ -11,3 +11,5 @@ do_install() {
11} 11}
12 12
13FILES_${PN} += "${base_libdir}/firmware/msvdx_fw.bin" 13FILES_${PN} += "${base_libdir}/firmware/msvdx_fw.bin"
14
15COMPATIBLE_MACHINE = "emenlow"
diff --git a/meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb b/meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb
index b6a0a3a..5c1a3e1 100644
--- a/meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb
+++ b/meta-emenlow/packages/psb-kernel-source/psb-kernel-source_4.42.0.bb
@@ -20,3 +20,5 @@ do_install () {
20FILES_${PN} += "${base_libdir}/modules/${KERNEL_VERSION}/extra/*.ko" 20FILES_${PN} += "${base_libdir}/modules/${KERNEL_VERSION}/extra/*.ko"
21 21
22DEPENDS += "virtual/kernel" 22DEPENDS += "virtual/kernel"
23
24COMPATIBLE_MACHINE = "emenlow"
diff --git a/meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb b/meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb
index d6ecdae..a732f08 100644
--- a/meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb
+++ b/meta-emenlow/packages/xorg-xserver/xserver-psb_1.7.99.2.bb
@@ -15,3 +15,5 @@ SRC_URI += "file://fix_open_max_preprocessor_error.patch;patch=1"
15EXTRA_OECONF += "--enable-dri --enable-dri2 --enable-dga --enable-glx" 15EXTRA_OECONF += "--enable-dri --enable-dri2 --enable-dga --enable-glx"
16 16
17DEPENDS += "psb-firmware xpsb-glx psb-kernel-source libdrm-poulsbo libva" 17DEPENDS += "psb-firmware xpsb-glx psb-kernel-source libdrm-poulsbo libva"
18
19COMPATBILE_MACHINE = "emenlow"
diff --git a/meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb b/meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb
index 4a27c9a..1e2fc7e 100644
--- a/meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb
+++ b/meta-emenlow/packages/xpsb-glx/xpsb-glx_0.18.bb
@@ -38,3 +38,5 @@ FILES_${PN} = "${libdir}/* ${libdir}/xorg/modules/dri/* \
38 38
39# Multiple virtual/gl providers being built breaks staging 39# Multiple virtual/gl providers being built breaks staging
40EXCLUDE_FROM_WORLD = "1" 40EXCLUDE_FROM_WORLD = "1"
41
42COMPATIBLE_MACHINE = "emenlow"
diff --git a/meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb b/meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
index fc014fc..efba6f6 100644
--- a/meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
+++ b/meta-emenlow/packages/xserver-xorg-video-psb/xserver-xorg-video-psb_0.32.1.bb
@@ -29,3 +29,5 @@ FILES_${PN} += "${libdir}/xorg/modules/drivers/libmm.so \
29 ${libdir}/xorg/modules/drivers/psb_drv.so" 29 ${libdir}/xorg/modules/drivers/psb_drv.so"
30 30
31DEPENDS += "virtual/libgl virtual/xserver" 31DEPENDS += "virtual/libgl virtual/xserver"
32
33COMPATIBLE_MACHINE = "emenlow"