diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2025-04-17 17:18:36 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2025-04-17 17:19:32 +0000 |
commit | f3feb82026b268912d627a4a04df979266137181 (patch) | |
tree | df6bca3640a8b3e8feb9f8261ef8afb3726e77b4 | |
parent | 1289579dd0def36245ade02e4dd3d0bc3c3e3af8 (diff) | |
download | meta-virtualization-f3feb82026b268912d627a4a04df979266137181.tar.gz |
gunicorn: update to 23.0.0
As well as the update, we move away from pure setuptools to
pyproject.toml and the meta backend.
Bumping gunicorn to version 23.0.0-13-ga86ea1e4, which comprises the following commits:
411986d6 fix doc
9357b28d keep document user in access_log_format setting
79fdef08 bump to 23.0.0
256d474a docs: revert duped directive
ffa48b58 test: default change was intentional
52538ca9 docs: recommend SCRIPT_NAME=/subfolder
687b78d2 config defaults: PATH_NAME and ::1 for proxy
5bbf373e undocumented allow-all for forwarder-headers
3e042e82 Configurable list of forwarder headers
01bcdb1d Exempt SCRIPT_NAME from newly introduced --header-map treatment
2bc931e7 whitespace handling in header field values
ce039ca7 Swap error/debug severity
6c3296e1 update docs
e3562c94 doc: news for 2024
6245e2c0 docs: unresolved reference (the reference is not named after the class name)
2a3dfdd2 CI: verify docs up to date
2c38b036 Update design.rst
555d2fa2 don't tolerate wrong te headers
5e39f886 Update tornadoapp.py
cabc6662 chunked encoding: example invalid requests
a3d130ae gracefully handle chunked encoding missing size
70a1e437 forbid lone CR/LF and NUL in headers (docs)
7c3e9c9c docs: clarify Makefile is generated
2669016a docs: https-capable sphinx homepage entry point
4b48ebe8 no docs/build in sdist
9ca4f1fd refuse empty request-target in HTTP request
eda9d456 forbid lone CR/LF and NUL in headers
e3fa50d1 update docs
0f200191 Document server hooks in a custom application
8fe034ef CI: run entry point tests without deps, run lint without package build steps
9949e34e CI: also try Python 3.13 (at this time beta 1)
3d006963 CI: revert macos-14 for Github runners
97f87ec1 Fix InvalidHTTPVersion exception str method
4f776658 Python 3.3+: replace deprecated aliases
ec85b32d Pythn 2.7+: open arg defaults to r
78ef73b6 Python3: super() args not typically needed
422b18ac class Name(object): -> class Name:
4323027b drop long-default - coding: utf-8
5b68c17b fix license year
f63d59e4 bump to 22.0
0243ec39 fix(deps): exclude eventlet 0.36.0
628a0bcb chore: fix typos
1954fb63 update example_config with latest settings
08364f03 Issue #3079, add unit test
deae2fc4 CI: back off the agressive timeout
f4703824 docs: promise 3.12 compat
5e30bfa6 add changelog to project.urls (updated for PEP621)
481c3f95 remove setup.cfg - overridden by pyproject.toml
89dcc5c5 CI: stop testing EoL PyPy
184e36f9 skip eventlet, not yet supported on python 3.12
b39c5b7e CI: style
0bb96d17 CI: tests may hang on PyPy
660fd8d8 Fix references to non-existent 20.2 version in configuration settings
e0c3390f Typo and email in Security.md
e710393d HTTP parser: stricter chunk-ext OBS handling
b6c7414f briefly document security fixes in 2023 news
7ebe442d strict HTTP version validation
f5501111 strict HTTP header field name validation
fd67112f Ignore secure_scheme_headers in Trailer section
ac29c9b0 fail-safe on unsupported request framing
0b10cbab unconditionally log request error
72b8970d silently drop or refuse header names w/ underscore
b2846783 strict: header field validation: stop casefolding
42dd4190 test: verify TOKEN_RE against common HTTP Methods
13027ef7 Create SECURITY.md
f0c91cca Check SCRIPT_NAME is at the request path's beginning
72238fcf RFC compliant request line and header parsing
735e9e86 Disallow empty header names.
2dbe49de RFC compliant header field+chunk validation
559caf92 pytest: raise on malformed test fixtures
611746ed CI: check entry points
c3396b97 github actions: cache and test run_module (-m)
40232284 let's exception not bubble ensure we can catch correctly exceptions based on BaseException.
7acd83bf pyproject.toml: fix license-files field
0dd6b635 Use `utime` instead of `fchmod` in WorkerTmp.notify
237f3e6f Remove Python2 note
a265b9cf news.rst: fix minor typo
4ce82358 Add Python 3.12 to test matrix and add classifiers
afe06802 Document Python 3.7 requirement
ca2ce2c7 Fix for issue #3079, worker_class parameter accepts a class
7d69222b Bump actions/checkout from 3 to 4
fdd23e82 migrate to pyproject.toml
7033f27e remove exclusion of tests and examples dir
760e8642 migrate to setup.cfg
ab9c8301 bump to 21.2.0
bc905859 revert change considering connection as idle
4e12ebe3 bump to 21.1.0
60b78e3d fix setup.cfg: use new license_files property
86d85cb3 fix gthread worker
547f8561 bump 21.0.1: fix doc
033dca60 fix doc path to conf.py in readthedocs.yaml
1dd24e6e fix .readthedocs.yaml path
b6eb01ba add readthedocs.yaml
543628eb remove pypy-3.7 from tests
91cb3dc6 Revert "remove cryptography from requirements"
471a6f80 remove cryptography from requirements
f628dd97 fix import error
cac38b42 bump doc version
0304f006 add minitimal changelog
f72acb6c add missing depedency for eventlet tests
1ff10ff9 remove useless dep
378f0d04 bump to 21.0.0
2f17eb50 Add a Dependabot config to keep GitHub action versions updated
fa94f705 Updating Content-Length Handling
dd0aebfc add to THANKS :)
cc15967c tox.ini deps
48d670f0 update pylint version, and fix linter issues
7f480daf replace pkg_resources.load_entry_point
858b743d remove double finally
6d4faab6 Log access even when connection is closed
d8c3b149 Deprecate ssl_version option
2b98f5e7 Fix username parsing for basic auth
ed9729a8 add missing double quote
0b5c4aea Fix LogRecord pre-formatting, closes #2801
a7ead983 fix basic auth logging
f19e31fe utils.py: fix code reference
e7781d2c gthread: consider intial connectino as idle
98653df9 Update setup.py
b8d6b1e9 Add myself to THANKS
72faa11e Replace pkg_resources.parse_version with packaging.version.parse
d04ddfd1 Docs: add link to configuration file
4d532c96 Update THANKS
2ea4699f Fixing errors reported by pycodestyle
f5d73aa7 GA workflows cleanup Working Matrix for both lint/tox Fixing tox v4 issues Adjust pylint to working version
30baeebf Revert "get address from tuple"
48eda22a Update tox.yml
0b2c6fd9 bump uses
0ebb73aa gthread: only read sockets when they are readable
2f9eb19b prepare for release
1efc5d91 irc is on libera
61d643f9 add myself to THANKS file
a41ee75c update irc channel docs
008d81d0 Update setup.py
b42af98e Add contributor
6766c086 Fix HTTP status code for Request Header Fields Too Large
91fee380 Remove Travis CI configuration
137b77d3 build: harden lint.yml permissions
4cf30b79 build: harden tox.yml permissions
9f159f7c docs: Add section for Gthread workers
c9d01c80 get address from tuple
69bf1d0c remove changes by isort and lint
4dff334f fix LevelLog in Arbiter.run()
7ef281fa readme: IRC channel has moved to libera.chat
1754d33e Add Python 3.10 classifier
f186fa3a Make loggers function atomic
7d8f68c1 Solving issue #2692
ac8bc3a4 Regenerated rst docs
cc3238c6 Prevent unnecessary setuid call
99447b08 Fix typo in deploy.rst
362a52bd Added parameter to ssl_context hook for constructing default context
71d6388f Replaced Travis CI badge with 2x gh actions badges for test and lint
19fb762b Split main tox test build and linters into two workflows.
80a62afc Updated THANKS.
eaebf6d7 Revert the xfail for Python 3.10
1feb7c59 Revert the xfail for Python 3.10
f587bfaf GitHub Action to run tox
a16b8975 GitHub Action to run tox
230cd034 Updated THANKS.
0b6939de Undo changes that make -R branch logic behave the same as non -R branch, that is, to close(0) and open /dev/null as fd=0 instead of fd=3.
e9c4f744 Revert "Refactoring: common stdin </dev/null."
eedc3a38 Refactoring: common stdin </dev/null.
835a4fc4 Ensure fd 0 stdin </dev/null is always inheritable.
e5a97150 fix chdir documentation typo (#2656)
cf3619f8 Fix typos
76f8da24 Revert "Log a warning when a worker was terminated due to a signal"
c30b0d9d Fix problem that may happen after interrupted chunk-encoding request
f639128b Fix sendfile behaviour for open files with non-zero offset.
141a8f3d docs: gthread is a sync worker
e3b0b1f9 integral? that took me a while to figure out
3a6649a9 Fix link
5a581c0b Update SSLContext handling
df82cac7 fix: gunicorn run tornado app failed
0215f5dc docs: add examples for cert-reqs
45687c35 Replace deprecated unittest alias
daacf39c Improve access-log-format documentation section
7d50d61f Fix calling condition for Arbiter.log.reopen_files()
90ef9a6a Add nginx documentation for proxy_ignore_client_abort
6a8ebb48 eventlet worker: ALREADY_HANDLED -> WSGI_LOCAL
927c604f Set daemon attribute instead of using setDaemon method that was deprecated in Python 3.10
cf55d2ce bump version
917ebcdd Fixes #1695
b83448bf Clarify the secure scheme behaviour, with examples (#2492)
fb05e333 Fix a naming error for gthread worker
3b8ce3df Added a line to the documentation to further explain the use of logconfig_dict
01f5d4dd Remove 2020 unreleased changelog
1cfb59ca Fix changelog lint
6fbe6a11 Clarify grammar in FAQ about worker restarts
426fe70a link to 2021
61ccfd6c bump to 20.1.0
540b7100 Use warning level for 'Bad request' logs
d1f0f11b fix inline code syntax in news
f87882e4 add an empty line in news.rst
7a79808d update changeslog
6fd97b95 Document that WEB_CONCURRENCY is set by, at least, Heroku
dad99a1b Update gunicorn_ext.py
32734928 Improve settings documentation
a4407abf Default to Python 3 version of gunicorn in Stretch
00e73b7e Update Debian and Ubuntu distribution information
28a4c1b2 Typo fixed in the AsyncIO docs
d7ff6053 Add Python 3.9 to PyPI classifiers
2ad21734 Enable Python 3.8 and Python 3.9 testing in AppVeyor
f376da2e Test on Python 3.9
37994e14 Remove the --log-config-dict flag
3573fd38 Capture peer name from accept
b695b497 Log a warning when a worker was terminated due to a signal
d8a12560 Document that gthread also uses worker_connections
da3b89b7 The signature of __init__ on the "fall through" InotifyReloader was missing the extra_files paramater, so specifying the inotify reload engine on the command line when one did not have inotify installed would, instead of a nice message about needed inotify installed would result in the following traceback:
548d5828 Remove reference to gunicorn/six.py in tox.ini (#2427)
5175471f be more explicit in the description of USR2 flow.
1d6f9029 Disable pylint raise-missing-from
ca36d410 Fix format call
28df9926 Add additional logs when worker exits abnormally
83319f75 fix: repair django wsgi running error
b3f9815a fix: don't enforce the content length
f2d8b6d1 Split long line
b80a3293 Correction on default value for config file (#2408)
d81c6cef Warn in the case of bad systemd configuration
2a16fcd3 Test and defend against the specific case where the statsd hostname is 'unix'
15abac7e Allow specifying a UDS socket address through --statsd-host
7e16d130 Port websocket examples to Python 3 (#2371)
e60a5591 Add project_urls and update to https
4b9afb47 Probably a typo
17e70dac ✨ Add support for python -m gunicorn
0d28529c Fixed two bugs related to gevent + gunicorn + statsd.
6aab4dec Add additional missing docs
d4339979 Update desc for Timeout
4ababc36 Correct systemd socket activation example
57a9e2eb Specify wsgi_app in config #1359.
79fc9a3b Log abnormal arbiter shutdown at error level
ee1e5c19 Log abnormal worker exit codes
4ae2a05c Disable keepalive during graceful shutdown
ebb41da4 Make force close on max requests consistent
8c5613b1 Revert "Exit async keepalive request loop when self.alive is False"
78960570 Exit keepalive request loop when self.alive is False
57b8cdff Document --timeout 0
3bf93193 Update gthread.py
f626830c Fix simple typo: convertable -> convertible
f8b1e84d Do not raise and crash worker on ENOTCONN error
f145e90e Set `max_accept` on `gevent` worker-class to 1 when workers > 1
f39b065d Validate directory before watching it with inotify
27d1e988 Fix issues #2133 and #2244
93bcf5a4 Replace and run the sitemap generator
83b78e09 Document the default name and path for the configuration file
a648f8a8 Document how environment variables impact configuration
c82996f7 Add documentation for the $PORT environment variable
d3070459 Add milliseconds option to request_time in access_log (#2218)
287916a5 Remove dead code: find_library and _findWalk_ldpath
9219da52 Updated setup Development Status metadata to 5 - Production/Stable (was 4 - Beta).
c1bea68f Added a set of pip requirements files to cover the examples in examples/frameworks.
f74f926f remove trailing new line
dcfd0f04 fix SERVER_SOFTWARE property
2f944c9b remove version from the Server header
2d40e6da Use socket.sendfile() instead of os.sendfile().
2ec7493b Updated requires Python to >= 3.5.
7cce20e9 Don't build universal wheel, since Python 2 support has been removed.
e5310d15 add os.path.abspath() in dirname generation of the reloader
cfc93ad7 Update FAQ - Workers Silently Killed.
5a57d595 Fix sample command syntax highlighting in run.rst
4ef01b1c Bumped py3 min version in setup.py to 3.5 (was 3.4).
9c147f66 Added Brett Randall to MAINTAINERS.
ed901637 Enable pycodestyle
ff1dbfec update site with the new version
00b58979 Update faq.rst
c5a254ad Update faq.rst
5858f815 Update faq.rst
9545e01d Update faq.rst
74cf2ce0 Update faq.rst and fix technical mistake on ulimit
b014fa78 Various code improvements contributed by dilyanpalauzov.
d1f6a778 Code style
5803f835 Added a possibility of logging the metrics to a Unix domain socket instead of UDP
000236aa Docs.
93d2687d f-strings only date back to Py3.6
13c5d72b Add --print-config option to print the resolved settings at startup.
2a0433e7 Update gunicorn/workers/workertmp.py
54d35d73 Fix #1965: About gunicorn [CRITICAL] Worker Timeout
d20a26a3 updated styling
e98f6a03 added capability to take JSON as log's config
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-devtools/python/gunicorn_23.0.0.bb (renamed from recipes-devtools/python/gunicorn_20.0.4.bb) | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-devtools/python/gunicorn_20.0.4.bb b/recipes-devtools/python/gunicorn_23.0.0.bb index 41c909c5..04ec0578 100644 --- a/recipes-devtools/python/gunicorn_20.0.4.bb +++ b/recipes-devtools/python/gunicorn_23.0.0.bb | |||
@@ -6,11 +6,11 @@ DESCRIPTION = "\ | |||
6 | simply implemented, light on server resource usage, and fairly speedy. \ | 6 | simply implemented, light on server resource usage, and fairly speedy. \ |
7 | " | 7 | " |
8 | LICENSE = "MIT" | 8 | LICENSE = "MIT" |
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f75f3fb94cdeab1d607e2adaa6077752" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5b70a8b30792a916f50dc96123e61ddf" |
10 | 10 | ||
11 | SRC_URI = "https://pypi.python.org/packages/source/g/gunicorn/${BPN}-${PV}.tar.gz" | 11 | SRC_URI = "https://pypi.python.org/packages/source/g/gunicorn/${BPN}-${PV}.tar.gz" |
12 | 12 | ||
13 | SRC_URI[md5sum] = "543669fcbb5739ee2af77184c5e571a1" | 13 | SRC_URI[md5sum] = "18b666db62a890579170639961c5b064" |
14 | SRC_URI[sha256sum] = "1904bb2b8a43658807108d59c3f3d56c2b6121a701161de0ddf9ad140073c626" | 14 | SRC_URI[sha256sum] = "f014447a0101dc57e294f6c18ca6b40227a4c90e9bdb586042628030cba004ec" |
15 | 15 | ||
16 | inherit setuptools3 | 16 | inherit python_pep517 python_setuptools_build_meta |