diff options
author | Yunguo Wei <yunguo.wei@windriver.com> | 2018-01-30 16:02:20 -0200 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2018-01-30 17:11:17 -0500 |
commit | ed7b8333e1f09d59dbe96ec1258971ffb4e5af41 (patch) | |
tree | 920d4c21143c856e2f5598b6b79afdc986e6d176 | |
parent | b38ebbee98d24b1fac1f1278bce1a7b4d337cf35 (diff) | |
download | meta-virtualization-ed7b8333e1f09d59dbe96ec1258971ffb4e5af41.tar.gz |
docker: override GOROOT at build time
Usually $GOROOT is set by go tool, but if sstate is specified, $GOROOT
is set to the path in the first project. If docker is built in the
another project(with same SSTATE_DIR) later, and the first project is removed,
the following error will be seen:
| go: cannot find GOROOT directory:
/path/to/previous/project/bitbake_build/tmp/sysroots/x86_64-linux/usr/lib/x86_64-wrs-linux/go
This commit is overriding $GOROOT stored in the go tool in sstate cache,
making sure it is set to the correct path in current project.
See more information here: https://golang.org/doc/install#install
Signed-off-by: Yunguo Wei <yunguo.wei@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
(cherry picked from commit 01aa8f18196d76d4554649c47348fb68277574c5)
-rw-r--r-- | recipes-containers/docker/docker_git.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb index 42a336e5..898957be 100644 --- a/recipes-containers/docker/docker_git.bb +++ b/recipes-containers/docker/docker_git.bb | |||
@@ -80,6 +80,7 @@ do_compile() { | |||
80 | mkdir -p .gopath/src/"$(dirname "${DOCKER_PKG}")" | 80 | mkdir -p .gopath/src/"$(dirname "${DOCKER_PKG}")" |
81 | ln -sf ../../../.. .gopath/src/"${DOCKER_PKG}" | 81 | ln -sf ../../../.. .gopath/src/"${DOCKER_PKG}" |
82 | export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" | 82 | export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" |
83 | export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" | ||
83 | cd - | 84 | cd - |
84 | 85 | ||
85 | # Pass the needed cflags/ldflags so that cgo | 86 | # Pass the needed cflags/ldflags so that cgo |