diff options
author | Bogdan Purcareata <bogdan.purcareata@freescale.com> | 2013-04-11 12:19:31 +0300 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2013-04-11 13:07:17 -0700 |
commit | 4c111373fc0b88ce14407e858a749fe3f2eff516 (patch) | |
tree | 3dfafd4660d6cabf33431277936495f5024d15b7 | |
parent | f46d6cbc4e8d20d8cc4350cf2c41e25133641fdd (diff) | |
download | meta-virtualization-4c111373fc0b88ce14407e858a749fe3f2eff516.tar.gz |
lxc: Add LXC 0.9.0 recipe
Introducing the LXC 0.9.0 recipe.
Maintainer log for intermediate versions since LXC 0.8.0. This only contains
the major differences between versions. You may find the complete log on the
SourceForge LXC devel mailing list [1].
0.9.0.alpha1:
- Introduction of the new liblxc API
- Python bindings
- New tools:
- lxc-device
- lxc-start-ephemeral
- python version of lxc-ls
- lxc.autodev support
- oracle template
- reworked lxc-attach
- /etc/lxc/lxc.conf configuration
- Switch to new docbook
- A lot of other improvements, new features and bugfixes
0.9.0.alpha2: bug fix for issue with 0.9.0.alpha1 - no significant changes
0.9.0.alpha3:
- Android support
- New lua binding
- User namespace support
- Oracle template
- Manpage updates
- POSIX shell support for most scripts
- Improved systemd support
- Various API improvements
- Logging improvements
0.9.0.rc1:
- Addition of -P option to all executables (to specify lxcpath)
- Rework of the cgroup handling code
- Rework of lxc-attach for userns
- Updates to the alpine, archlinux, opensuse, oracle and ubuntu
templates. Removal of the lenny template.
- Introduction of a new lxc.stopsignal option
- Introduction of a new lxc.kmsg option
- Various userns improvements
- New --host option in lxc-ps
- Introduction of a few examples lxc hooks
- Support for nested containers in lxc-ls
- Introduction of get_version in the C API.
- And a variety of bugfixes
0.9.0:
Feature changes include:
- Support for ephemeral containers in lxc-clone
- --clear-env/--keep-env support in lxc-attach
- -n option to lxc-start-ephemeral
Everything else is bugfixes on top of rc1.
Tests done by maintainers:
- Test build on my machine (up to date Ubuntu 13.04)
- Test build on Launchpad (Ubuntu 12.04, 12.10 and 13.04)
- Test build on an armhf board running Ubuntu 13.04
- Test build for Android cross-compiling on my laptop
- Ran our test suite on the x86 binaries
- Ran a quick test (start/stop/info/wait) on Android
- Tested the API and tools on ARM
- Rebuilt all my local templates (~20 containers) on a variety of
architectures (i386, amd64, armel and armhf)
[1] https://lists.sourceforge.net/lists/listinfo/lxc-develIntroducing the LXC 0.9.0 recipe.
Signed-off-by: Bogdan Purcareata <bogdan.purcareata@freescale.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-containers/lxc/lxc_0.9.0.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-containers/lxc/lxc_0.9.0.bb b/recipes-containers/lxc/lxc_0.9.0.bb new file mode 100644 index 00000000..292285d6 --- /dev/null +++ b/recipes-containers/lxc/lxc_0.9.0.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | DESCRIPTION = "lxc aims to use these new functionnalities to provide an userspace container object" | ||
2 | SECTION = "console/utils" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | ||
5 | PRIORITY = "optional" | ||
6 | PR = "r1" | ||
7 | DEPENDS = "libxml2 libcap" | ||
8 | RDEPENDS_${PN} = " \ | ||
9 | rsync \ | ||
10 | gzip \ | ||
11 | libcap-bin \ | ||
12 | bridge-utils \ | ||
13 | dnsmasq \ | ||
14 | perl-module-strict \ | ||
15 | perl-module-getopt-long \ | ||
16 | perl-module-vars \ | ||
17 | perl-module-warnings-register \ | ||
18 | perl-module-exporter \ | ||
19 | perl-module-constant \ | ||
20 | perl-module-overload \ | ||
21 | perl-module-exporter-heavy \ | ||
22 | " | ||
23 | |||
24 | SRC_URI = "http://lxc.sourceforge.net/download/lxc/${PN}-${PV}.tar.gz \ | ||
25 | " | ||
26 | SRC_URI[md5sum] = "8552a4479090616f4bc04d8473765fc9" | ||
27 | SRC_URI[sha256sum] = "1e1767eae6cc5fbf892c0e193d25da420ba19f2db203716c38f7cdea3b654120" | ||
28 | |||
29 | S = "${WORKDIR}/${PN}-${PV}" | ||
30 | |||
31 | PACKAGECONFIG ??= "" | ||
32 | PACKAGECONFIG[doc] = "--enable-doc,--disable-doc" | ||
33 | PACKAGECONFIG[rpath] = "--enable-rpath,--disable-rpath" | ||
34 | PACKAGECONFIG[apparmour] = "--enable-apparmor,--disable-apparmor,apparmor,apparmor" | ||
35 | |||
36 | inherit autotools | ||
37 | |||
38 | FILES_${PN}-dbg += "${libexecdir}/lxc/.debug" | ||