summaryrefslogtreecommitdiffstats
path: root/recipes-security/selinux
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2013-12-31 04:20:11 -0500
committerMark Hatle <mark.hatle@windriver.com>2014-01-10 14:13:44 -0600
commitfd8729d82d7667e60faeff863ee9c192240582a3 (patch)
tree072962445f38747b9bbeabce9970df3d9368f567 /recipes-security/selinux
parent9bd03e1bddb9348656d368a19fb6b57e94073847 (diff)
downloadmeta-selinux-fd8729d82d7667e60faeff863ee9c192240582a3.tar.gz
libsepol: migrate SRC_URI to 2.2
Removed patch and ported changes to 2.2 bbfile: - libsepol-Change-ranlib-for-cross-compiling.patch Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'recipes-security/selinux')
-rw-r--r--recipes-security/selinux/libsepol.inc5
-rw-r--r--recipes-security/selinux/libsepol/libsepol-Change-ranlib-for-cross-compiling.patch31
-rw-r--r--recipes-security/selinux/libsepol_2.2.bb8
-rw-r--r--recipes-security/selinux/libsepol_git.bb4
4 files changed, 8 insertions, 40 deletions
diff --git a/recipes-security/selinux/libsepol.inc b/recipes-security/selinux/libsepol.inc
index 8f0dc33..b7509e2 100644
--- a/recipes-security/selinux/libsepol.inc
+++ b/recipes-security/selinux/libsepol.inc
@@ -10,5 +10,8 @@ LICENSE = "LGPLv2+"
10 10
11inherit lib_package 11inherit lib_package
12 12
13BBCLASSEXTEND = "native" 13# Change RANLIB for cross compiling, use host-tools $(AR) rather than
14# local ranlib.
15EXTRA_OEMAKE += "RANLIB='$(AR) s'"
14 16
17BBCLASSEXTEND = "native"
diff --git a/recipes-security/selinux/libsepol/libsepol-Change-ranlib-for-cross-compiling.patch b/recipes-security/selinux/libsepol/libsepol-Change-ranlib-for-cross-compiling.patch
deleted file mode 100644
index f2fc313..0000000
--- a/recipes-security/selinux/libsepol/libsepol-Change-ranlib-for-cross-compiling.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 2ee1e9651ec4aa78daf15dfef74e0b6aaeb8db1e Mon Sep 17 00:00:00 2001
2From: Xin Ouyang <Xin.Ouyang@windriver.com>
3Date: Tue, 21 Feb 2012 14:47:45 +0800
4Subject: [PATCH] libsepol: Change ranlib for cross compiling.
5
6Use target host-tools to encapsulate any difference between local tools
7on different machines. For example, on local PC, libsepol.a's index could
8be added successfully by local ranlib, however, it will fail on some sever,
9so we'd better use host-tools $(AR) rather than any local ranlib.
10
11Signed-off-by: Harry Ciao<qingtao.cao@windriver.com>
12---
13 src/Makefile | 2 +-
14 1 files changed, 1 insertions(+), 1 deletions(-)
15
16diff --git a/src/Makefile b/src/Makefile
17index cd8e767..beea232 100644
18--- a/src/Makefile
19+++ b/src/Makefile
20@@ -21,7 +21,7 @@ all: $(LIBA) $(LIBSO) $(LIBPC)
21
22 $(LIBA): $(OBJS)
23 $(AR) rcs $@ $^
24- ranlib $@
25+ $(AR) s $@
26
27 $(LIBSO): $(LOBJS)
28 $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $^ -Wl,-soname,$(LIBSO),--version-script=libsepol.map,-z,defs
29--
301.7.5.4
31
diff --git a/recipes-security/selinux/libsepol_2.2.bb b/recipes-security/selinux/libsepol_2.2.bb
index efedb63..b4d717c 100644
--- a/recipes-security/selinux/libsepol_2.2.bb
+++ b/recipes-security/selinux/libsepol_2.2.bb
@@ -1,11 +1,9 @@
1PR = "r0" 1PR = "r0"
2 2
3include selinux_20130423.inc 3include selinux_20131030.inc
4include ${BPN}.inc 4include ${BPN}.inc
5 5
6LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" 6LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
7 7
8SRC_URI[md5sum] = "980964224683fa29d4ed65beb94b56ee" 8SRC_URI[md5sum] = "41cbe38ea809b5752f520bdeac4d2cf8"
9SRC_URI[sha256sum] = "290d17f583635a4a5d8a2141511272adf0571c4205cdea38b5a68df20d58a70b" 9SRC_URI[sha256sum] = "77a4b27006295805bdbd7f240038cb32a49be1d60847d413899501702933fc0f"
10
11SRC_URI += "file://libsepol-Change-ranlib-for-cross-compiling.patch"
diff --git a/recipes-security/selinux/libsepol_git.bb b/recipes-security/selinux/libsepol_git.bb
index 1fa83a4..bc2bd8f 100644
--- a/recipes-security/selinux/libsepol_git.bb
+++ b/recipes-security/selinux/libsepol_git.bb
@@ -1,9 +1,7 @@
1PR = "r0" 1PR = "r0"
2PV = "2.1.9+git${SRCPV}" 2PV = "2.2+git${SRCPV}"
3 3
4include selinux_git.inc 4include selinux_git.inc
5include ${BPN}.inc 5include ${BPN}.inc
6 6
7LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" 7LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
8
9SRC_URI += "file://libsepol-Change-ranlib-for-cross-compiling.patch"