diff options
author | Joe MacDonald <joe_macdonald@mentor.com> | 2014-09-16 21:05:00 -0400 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2014-09-24 08:52:17 -0400 |
commit | e0a92ce7b2da899da8a2e2884eca9fd74aa12763 (patch) | |
tree | 44a262aad380a355d5e1fb76b46878eedbdf5599 | |
parent | af4937c07eadb13d829c1ef278bed6528a2603a5 (diff) | |
download | meta-selinux-e0a92ce7b2da899da8a2e2884eca9fd74aa12763.tar.gz |
Globally replace 'base_contains' calls with 'bb.utils.contains'
Based on oe-core commit:
commit 1528e596d4906c33e4be83fcf691cfe76d340ff3
Author: Otavio Salvador <otavio@ossystems.com.br>
Date: Thu Apr 24 15:59:20 2014 -0300
Globally replace 'base_contains' calls with 'bb.utils.contains'
The base_contains is kept as a compatibility method and we ought to not
use it in OE-Core so we can remove it from base metadata in future.
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | classes/selinux.bbclass | 2 | ||||
-rw-r--r-- | recipes-extended/tar/tar_1.27.1.bbappend | 2 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-yocto_3.14.bbappend | 4 | ||||
-rw-r--r-- | recipes-security/audit/audit_2.3.2.bb | 2 | ||||
-rw-r--r-- | recipes-security/selinux/policycoreutils.inc | 6 |
5 files changed, 8 insertions, 8 deletions
diff --git a/classes/selinux.bbclass b/classes/selinux.bbclass index f9db49c..fb0df27 100644 --- a/classes/selinux.bbclass +++ b/classes/selinux.bbclass | |||
@@ -1,5 +1,5 @@ | |||
1 | def target_selinux(d, truevar = 'selinux', falsevar = ''): | 1 | def target_selinux(d, truevar = 'selinux', falsevar = ''): |
2 | if not base_contains("DISTRO_FEATURES", "selinux", True, False, d): | 2 | if not bb.utils.contains("DISTRO_FEATURES", "selinux", True, False, d): |
3 | return falsevar | 3 | return falsevar |
4 | 4 | ||
5 | pn = d.getVar("PN", True) | 5 | pn = d.getVar("PN", True) |
diff --git a/recipes-extended/tar/tar_1.27.1.bbappend b/recipes-extended/tar/tar_1.27.1.bbappend index 8e45037..a1dc99c 100644 --- a/recipes-extended/tar/tar_1.27.1.bbappend +++ b/recipes-extended/tar/tar_1.27.1.bbappend | |||
@@ -5,7 +5,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | |||
5 | inherit with-selinux | 5 | inherit with-selinux |
6 | 6 | ||
7 | 7 | ||
8 | PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}" | 8 | PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}" |
9 | 9 | ||
10 | # configure has no acl enable/disable options! | 10 | # configure has no acl enable/disable options! |
11 | # | 11 | # |
diff --git a/recipes-kernel/linux/linux-yocto_3.14.bbappend b/recipes-kernel/linux/linux-yocto_3.14.bbappend index 4118cc0..65c79ef 100644 --- a/recipes-kernel/linux/linux-yocto_3.14.bbappend +++ b/recipes-kernel/linux/linux-yocto_3.14.bbappend | |||
@@ -1,8 +1,8 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
2 | 2 | ||
3 | # Enable selinux support in the kernel if the feature is enabled | 3 | # Enable selinux support in the kernel if the feature is enabled |
4 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'selinux', 'file://selinux.cfg', '', d)}" | 4 | SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'file://selinux.cfg', '', d)}" |
5 | 5 | ||
6 | # For inconsistent kallsyms data bug on ARM | 6 | # For inconsistent kallsyms data bug on ARM |
7 | # http://lists.infradead.org/pipermail/linux-arm-kernel/2012-March/thread.html#89718 | 7 | # http://lists.infradead.org/pipermail/linux-arm-kernel/2012-March/thread.html#89718 |
8 | EXTRA_OEMAKE += "${@base_contains('TARGET_ARCH', 'arm', ' KALLSYMS_EXTRA_PASS=1', '', d)}" | 8 | EXTRA_OEMAKE += "${@bb.utils.contains('TARGET_ARCH', 'arm', ' KALLSYMS_EXTRA_PASS=1', '', d)}" |
diff --git a/recipes-security/audit/audit_2.3.2.bb b/recipes-security/audit/audit_2.3.2.bb index 4baf7a0..96b19c8 100644 --- a/recipes-security/audit/audit_2.3.2.bb +++ b/recipes-security/audit/audit_2.3.2.bb | |||
@@ -84,7 +84,7 @@ do_install_append() { | |||
84 | install -D -m 0755 ${S}/../auditd ${D}/etc/init.d/auditd | 84 | install -D -m 0755 ${S}/../auditd ${D}/etc/init.d/auditd |
85 | rm -rf ${D}/etc/rc.d | 85 | rm -rf ${D}/etc/rc.d |
86 | 86 | ||
87 | if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then | 87 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
88 | install -d ${D}${sysconfdir}/tmpfiles.d/ | 88 | install -d ${D}${sysconfdir}/tmpfiles.d/ |
89 | install -m 0644 ${WORKDIR}/audit-volatile.conf ${D}${sysconfdir}/tmpfiles.d/ | 89 | install -m 0644 ${WORKDIR}/audit-volatile.conf ${D}${sysconfdir}/tmpfiles.d/ |
90 | fi | 90 | fi |
diff --git a/recipes-security/selinux/policycoreutils.inc b/recipes-security/selinux/policycoreutils.inc index a4d174c..153b688 100644 --- a/recipes-security/selinux/policycoreutils.inc +++ b/recipes-security/selinux/policycoreutils.inc | |||
@@ -7,7 +7,7 @@ context." | |||
7 | SECTION = "base" | 7 | SECTION = "base" |
8 | LICENSE = "GPLv2+" | 8 | LICENSE = "GPLv2+" |
9 | 9 | ||
10 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}" | 10 | SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}" |
11 | 11 | ||
12 | PAM_SRC_URI = "file://pam.d/newrole \ | 12 | PAM_SRC_URI = "file://pam.d/newrole \ |
13 | file://pam.d/run_init \ | 13 | file://pam.d/run_init \ |
@@ -154,7 +154,7 @@ FILES_${PN}-loadpolicy += "\ | |||
154 | " | 154 | " |
155 | FILES_${PN}-newrole += "\ | 155 | FILES_${PN}-newrole += "\ |
156 | ${bindir}/newrole \ | 156 | ${bindir}/newrole \ |
157 | ${@base_contains('DISTRO_FEATURES', 'pam', '${sysconfdir}/pam.d/newrole', '', d)} \ | 157 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${sysconfdir}/pam.d/newrole', '', d)} \ |
158 | " | 158 | " |
159 | FILES_${PN}-python = "\ | 159 | FILES_${PN}-python = "\ |
160 | ${libdir}/python${PYTHON_BASEVERSION}/site-packages/seobject.py* \ | 160 | ${libdir}/python${PYTHON_BASEVERSION}/site-packages/seobject.py* \ |
@@ -164,7 +164,7 @@ FILES_${PN}-python = "\ | |||
164 | FILES_${PN}-runinit += "\ | 164 | FILES_${PN}-runinit += "\ |
165 | ${sbindir}/run_init \ | 165 | ${sbindir}/run_init \ |
166 | ${sbindir}/open_init_pty \ | 166 | ${sbindir}/open_init_pty \ |
167 | ${@base_contains('DISTRO_FEATURES', 'pam', '${sysconfdir}/pam.d/run_init', '', d)} \ | 167 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${sysconfdir}/pam.d/run_init', '', d)} \ |
168 | " | 168 | " |
169 | FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/site-packages/sepolicy/.debug/*" | 169 | FILES_${PN}-dbg += "${libdir}/python${PYTHON_BASEVERSION}/site-packages/sepolicy/.debug/*" |
170 | FILES_${PN}-sandbox += "\ | 170 | FILES_${PN}-sandbox += "\ |