summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@konsulko.com>2020-11-25 15:33:57 +0000
committerAndrei Gherzan <andrei@gherzan.ro>2020-11-27 14:29:55 +0000
commitba3a417fbbccb5f6af9ac036eac97c87dcf4c1b7 (patch)
treed2adfc8753f747636022f5dabe5258945fcdb69a
parentb8440b3d26fc0b59acd48ed6f3e39e00cd867f6c (diff)
downloadmeta-raspberrypi-ba3a417fbbccb5f6af9ac036eac97c87dcf4c1b7.tar.gz
rpi-bootfiles: Rename recipe to avoid ambiguity
The name `bootfiles` is too generic, we should use `rpi-bootfiles` instead. Signed-off-by: Paul Barker <pbarker@konsulko.com>
-rw-r--r--classes/sdcard_image-rpi.bbclass5
-rw-r--r--conf/machine/include/rpi-base.inc2
-rw-r--r--recipes-bsp/bootfiles/rpi-bootfiles.bb (renamed from recipes-bsp/bootfiles/bootfiles.bb)0
3 files changed, 2 insertions, 5 deletions
diff --git a/classes/sdcard_image-rpi.bbclass b/classes/sdcard_image-rpi.bbclass
index ba50aa5..0ae98cd 100644
--- a/classes/sdcard_image-rpi.bbclass
+++ b/classes/sdcard_image-rpi.bbclass
@@ -25,9 +25,6 @@ inherit image_types
25# This image depends on the rootfs image 25# This image depends on the rootfs image
26IMAGE_TYPEDEP_rpi-sdimg = "${SDIMG_ROOTFS_TYPE}" 26IMAGE_TYPEDEP_rpi-sdimg = "${SDIMG_ROOTFS_TYPE}"
27 27
28# Set kernel and boot loader
29IMAGE_BOOTLOADER ?= "bootfiles"
30
31# Kernel image name 28# Kernel image name
32SDIMG_KERNELIMAGE_raspberrypi ?= "kernel.img" 29SDIMG_KERNELIMAGE_raspberrypi ?= "kernel.img"
33SDIMG_KERNELIMAGE_raspberrypi2 ?= "kernel7.img" 30SDIMG_KERNELIMAGE_raspberrypi2 ?= "kernel7.img"
@@ -56,7 +53,7 @@ do_image_rpi_sdimg[depends] = " \
56 mtools-native:do_populate_sysroot \ 53 mtools-native:do_populate_sysroot \
57 dosfstools-native:do_populate_sysroot \ 54 dosfstools-native:do_populate_sysroot \
58 virtual/kernel:do_deploy \ 55 virtual/kernel:do_deploy \
59 ${IMAGE_BOOTLOADER}:do_deploy \ 56 rpi-bootfiles:do_deploy \
60 ${@bb.utils.contains('MACHINE_FEATURES', 'armstub', 'armstubs:do_deploy', '' ,d)} \ 57 ${@bb.utils.contains('MACHINE_FEATURES', 'armstub', 'armstubs:do_deploy', '' ,d)} \
61 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \ 58 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \
62 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot-default-script:do_deploy', '',d)} \ 59 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot-default-script:do_deploy', '',d)} \
diff --git a/conf/machine/include/rpi-base.inc b/conf/machine/include/rpi-base.inc
index d4a25a4..18368c6 100644
--- a/conf/machine/include/rpi-base.inc
+++ b/conf/machine/include/rpi-base.inc
@@ -123,7 +123,7 @@ IMAGE_BOOT_FILES ?= "${BOOTFILES_DIR_NAME}/* \
123 '${KERNEL_IMAGETYPE};${SDIMG_KERNELIMAGE}', d)} \ 123 '${KERNEL_IMAGETYPE};${SDIMG_KERNELIMAGE}', d)} \
124 " 124 "
125do_image_wic[depends] += " \ 125do_image_wic[depends] += " \
126 bootfiles:do_deploy \ 126 rpi-bootfiles:do_deploy \
127 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \ 127 ${@bb.utils.contains('RPI_USE_U_BOOT', '1', 'u-boot:do_deploy', '',d)} \
128 " 128 "
129 129
diff --git a/recipes-bsp/bootfiles/bootfiles.bb b/recipes-bsp/bootfiles/rpi-bootfiles.bb
index f1248ee..f1248ee 100644
--- a/recipes-bsp/bootfiles/bootfiles.bb
+++ b/recipes-bsp/bootfiles/rpi-bootfiles.bb