diff options
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-return-type-of-lParseOperator.patch | 51 | ||||
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.22.0.bb (renamed from dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.21.1.bb) | 5 |
2 files changed, 54 insertions, 2 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-return-type-of-lParseOperator.patch b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-return-type-of-lParseOperator.patch new file mode 100644 index 0000000..6ef6cba --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc/0001-Fix-return-type-of-lParseOperator.patch | |||
@@ -0,0 +1,51 @@ | |||
1 | From 1d1b0f4eacb7d3875d7dd53e2df8dfca2031fa3a Mon Sep 17 00:00:00 2001 | ||
2 | From: Aleksei Nurmukhametov <aleksei.nurmukhametov@intel.com> | ||
3 | Date: Tue, 28 Nov 2023 04:11:44 -0800 | ||
4 | Subject: [PATCH] Fix return type of lParseOperator | ||
5 | |||
6 | When bison is used in -y mode that emulates POSIX Yacc, tokens are | ||
7 | defined as enums (under YYTOKENTYPE ifdef) or as int via macro | ||
8 | definitions. Defining return type as yytokentype causes compile error: | ||
9 | invalid conversion from 'int' to 'yytokentype'. To avoid it, return int | ||
10 | as we do with lParseInteger and lParseFP. | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/ispc/ispc/pull/2709] | ||
13 | |||
14 | Signed-off-by: Aleksei Nurmukhametov <aleksei.nurmukhametov@intel.com> | ||
15 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
16 | --- | ||
17 | src/lex.ll | 4 ++-- | ||
18 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
19 | |||
20 | diff --git a/src/lex.ll b/src/lex.ll | ||
21 | index f9e47578..0279831d 100644 | ||
22 | --- a/src/lex.ll | ||
23 | +++ b/src/lex.ll | ||
24 | @@ -20,6 +20,7 @@ using namespace ispc; | ||
25 | static uint64_t lParseBinary(const char *ptr, SourcePos pos, char **endPtr); | ||
26 | static int lParseInteger(bool dotdotdot); | ||
27 | static int lParseFP(); | ||
28 | +static int lParseOperator(const char *ptr); | ||
29 | static void lCComment(SourcePos *); | ||
30 | static void lCppComment(SourcePos *); | ||
31 | static void lNextValidChar(SourcePos *, char const*&); | ||
32 | @@ -29,7 +30,6 @@ static bool lConsumePragma(YYSTYPE *, SourcePos *); | ||
33 | static void lHandleCppHash(SourcePos *); | ||
34 | static void lStringConst(YYSTYPE *, SourcePos *); | ||
35 | static double lParseHexFloat(const char *ptr); | ||
36 | -static yytokentype lParseOperator(const char *ptr); | ||
37 | extern const char *RegisterDependency(const std::string &fileName); | ||
38 | |||
39 | #define YY_USER_ACTION \ | ||
40 | @@ -1162,7 +1162,7 @@ lParseHexFloat(const char *ptr) { | ||
41 | |||
42 | /** Parse an operator. | ||
43 | */ | ||
44 | -static yytokentype | ||
45 | +static int | ||
46 | lParseOperator(const char *ptr) { | ||
47 | yylval.stringVal = new std::string(ptr); | ||
48 | if (m->symbolTable->LookupFunctionTemplate(yytext)) | ||
49 | -- | ||
50 | 2.37.3 | ||
51 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.21.1.bb b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.22.0.bb index 53e88f6..4b434bb 100644 --- a/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.21.1.bb +++ b/dynamic-layers/openembedded-layer/recipes-core/ispc/ispc_1.22.0.bb | |||
@@ -11,14 +11,15 @@ inherit cmake python3native ptest | |||
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
14 | SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=releases/1.21.x \ | 14 | SRC_URI = "git://github.com/ispc/ispc.git;protocol=https;branch=main \ |
15 | file://0002-cmake-don-t-build-for-32-bit-targets.patch \ | 15 | file://0002-cmake-don-t-build-for-32-bit-targets.patch \ |
16 | file://0001-Fix-QA-Issues.patch \ | 16 | file://0001-Fix-QA-Issues.patch \ |
17 | file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \ | 17 | file://0001-Add-print-function-to-print-test-run-status-in-ptest.patch \ |
18 | file://0001-Fix-return-type-of-lParseOperator.patch \ | ||
18 | file://run-ptest \ | 19 | file://run-ptest \ |
19 | " | 20 | " |
20 | 21 | ||
21 | SRCREV = "a0e8e48169f35a129941475c7023920e968dbc31" | 22 | SRCREV = "bd2c42d42e0cc3da1baf92160b82d4dc820a02ee" |
22 | 23 | ||
23 | COMPATIBLE_HOST = '(x86_64).*-linux' | 24 | COMPATIBLE_HOST = '(x86_64).*-linux' |
24 | 25 | ||