diff options
author | Tom Zanussi <tom.zanussi@intel.com> | 2011-07-12 14:38:17 (GMT) |
---|---|---|
committer | Tom Zanussi <tom.zanussi@intel.com> | 2011-08-03 17:11:00 (GMT) |
commit | ea897ce72602c7b8f1f11aafe8baf6cbe5887c4c (patch) | |
tree | 70b17505ae2e4a27a5c22616ebf5f95f1da4c60a /meta-fri2/conf | |
parent | 724b13a74e068b7cd018cd8b2e18c2a762881d1d (diff) | |
download | meta-intel-ea897ce72602c7b8f1f11aafe8baf6cbe5887c4c.tar.gz |
meta-fri2: new layer for Fish River Island II (E6XX/EG20T) systems
This layer provides support for E6XX + EG20T Intel systems.
Currently it supports only vesa graphics, which will be upgraded
shortly.
Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta-fri2/conf')
-rw-r--r-- | meta-fri2/conf/layer.conf | 10 | ||||
-rw-r--r-- | meta-fri2/conf/machine/fri2.conf | 36 |
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-fri2/conf/layer.conf b/meta-fri2/conf/layer.conf new file mode 100644 index 0000000..b30e776 --- /dev/null +++ b/meta-fri2/conf/layer.conf | |||
@@ -0,0 +1,10 @@ | |||
1 | # We have a conf and classes directory, add to BBPATH | ||
2 | BBPATH := "${BBPATH}:${LAYERDIR}" | ||
3 | |||
4 | # We have a recipes directory, add to BBFILES | ||
5 | BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb \ | ||
6 | ${LAYERDIR}/recipes-*/*/*.bbappend" | ||
7 | |||
8 | BBFILE_COLLECTIONS += "fri2" | ||
9 | BBFILE_PATTERN_fri2 := "^${LAYERDIR}/" | ||
10 | BBFILE_PRIORITY_fri2 = "6" | ||
diff --git a/meta-fri2/conf/machine/fri2.conf b/meta-fri2/conf/machine/fri2.conf new file mode 100644 index 0000000..61b102d --- /dev/null +++ b/meta-fri2/conf/machine/fri2.conf | |||
@@ -0,0 +1,36 @@ | |||
1 | #@TYPE: Machine | ||
2 | #@NAME: fri2 | ||
3 | |||
4 | #@DESCRIPTION: Machine configuration for Fish River Island II systems | ||
5 | # i.e. E660 + EG20T | ||
6 | |||
7 | include conf/machine/include/tune-atom.inc | ||
8 | |||
9 | MACHINE_FEATURES = "kernel26 screen keyboard pci usbhost ext2 ext3 x86 \ | ||
10 | acpi serial usbgadget" | ||
11 | |||
12 | KERNEL_IMAGETYPE = "bzImage" | ||
13 | |||
14 | PREFERRED_PROVIDER_virtual/kernel = "linux-yocto" | ||
15 | PREFERRED_VERSION_linux-yocto = "3.0+git%" | ||
16 | |||
17 | PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto" | ||
18 | PREFERRED_PROVIDER_virtual/libx11 ?= "libx11-trim" | ||
19 | PREFERRED_PROVIDER_virtual/libgl ?= "mesa-dri" | ||
20 | PREFERRED_PROVIDER_virtual/xserver ?= "xserver-xf86-dri-lite" | ||
21 | PREFERRED_PROVIDER_virtual/xserver-xf86 ?= "xserver-xf86-dri-lite" | ||
22 | XSERVER ?= "xserver-xf86-dri-lite \ | ||
23 | xf86-input-mouse \ | ||
24 | xf86-input-keyboard \ | ||
25 | xf86-input-evdev \ | ||
26 | xf86-input-synaptics \ | ||
27 | xf86-video-vesa" | ||
28 | |||
29 | SERIAL_CONSOLE = "115200 ttyS0" | ||
30 | |||
31 | MACHINE_EXTRA_RRECOMMENDS = "kernel-modules eee-acpi-scripts" | ||
32 | |||
33 | IMAGE_FSTYPES ?= "ext3 cpio.gz live" | ||
34 | |||
35 | GLIBC_ADDONS = "nptl" | ||
36 | GLIBC_EXTRA_OECONF = "--with-tls" | ||