diff options
author | Saul Wold <sgw@linux.intel.com> | 2017-02-09 20:50:16 (GMT) |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2017-02-10 15:52:49 (GMT) |
commit | 69af9a33bb9968074d06a97353a795c5ebbb6860 (patch) | |
tree | a7b9613033cb2cd0d649cc1880c24567aabdc7c9 | |
parent | 66cb81c1b39c6714749fe0e0ba611630454751e4 (diff) | |
download | meta-intel-69af9a33bb9968074d06a97353a795c5ebbb6860.tar.gz |
zlib-qat: Add patch to support MUSL
MUSL has a stricter policy for header inclusion, so add patch
to explictly include pthread.h
Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r-- | common/recipes-extended/zlib-qat/zlib-qat/0001-qat_zlib.h-Add-pthread.h-for-MUSL.patch | 29 | ||||
-rw-r--r-- | common/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb | 4 |
2 files changed, 33 insertions, 0 deletions
diff --git a/common/recipes-extended/zlib-qat/zlib-qat/0001-qat_zlib.h-Add-pthread.h-for-MUSL.patch b/common/recipes-extended/zlib-qat/zlib-qat/0001-qat_zlib.h-Add-pthread.h-for-MUSL.patch new file mode 100644 index 0000000..b45ae79 --- /dev/null +++ b/common/recipes-extended/zlib-qat/zlib-qat/0001-qat_zlib.h-Add-pthread.h-for-MUSL.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 30c4a1181cbe696dd1b9f52c8e9422ef8c331e8f Mon Sep 17 00:00:00 2001 | ||
2 | From: Saul Wold <sgw@linux.intel.com> | ||
3 | Date: Thu, 9 Feb 2017 12:40:47 -0800 | ||
4 | Subject: [PATCH] qat_zlib.h: Add pthread.h for MUSL | ||
5 | |||
6 | MUSL is stricter when it comes to header file inclusion, so add | ||
7 | the additional header thats needed to compile with MUSL. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Saul Wold <sgw@linux.intel.com> | ||
11 | --- | ||
12 | qat_zlib.h | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/qat_zlib.h b/qat_zlib.h | ||
16 | index 2747f84..d9ac312 100644 | ||
17 | --- a/qat_zlib.h | ||
18 | +++ b/qat_zlib.h | ||
19 | @@ -8,6 +8,7 @@ | ||
20 | #include <stdlib.h> | ||
21 | #include <assert.h> | ||
22 | #include <time.h> | ||
23 | +#include <pthread.h> | ||
24 | |||
25 | #include "cpa_dc.h" | ||
26 | #ifdef USE_QAE_MEM | ||
27 | -- | ||
28 | 2.7.4 | ||
29 | |||
diff --git a/common/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb b/common/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb index d46e5fe..f5b247b 100644 --- a/common/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb +++ b/common/recipes-extended/zlib-qat/zlib-qat_0.4.7-002.bb | |||
@@ -22,6 +22,7 @@ SRC_URI = "http://www.zlib.net/zlib-${ZLIB_VERSION}.tar.gz;name=zlib \ | |||
22 | file://zlib-qat-0.4.7-002-zlib-qat-add-a-install-target-to-makefile.patch \ | 22 | file://zlib-qat-0.4.7-002-zlib-qat-add-a-install-target-to-makefile.patch \ |
23 | file://zlib-qat-0.4.7-002-zlib-Remove-rpaths-from-makefile.patch \ | 23 | file://zlib-qat-0.4.7-002-zlib-Remove-rpaths-from-makefile.patch \ |
24 | " | 24 | " |
25 | SRC_URI_append_libc-musl = " file://0001-qat_zlib.h-Add-pthread.h-for-MUSL.patch" | ||
25 | 26 | ||
26 | SRC_URI[zlib.md5sum] = "44d667c142d7cda120332623eab69f40" | 27 | SRC_URI[zlib.md5sum] = "44d667c142d7cda120332623eab69f40" |
27 | SRC_URI[zlib.sha256sum] = "36658cb768a54c1d4dec43c3116c27ed893e88b02ecfcb44f2166f9c0b7f2a0d" | 28 | SRC_URI[zlib.sha256sum] = "36658cb768a54c1d4dec43c3116c27ed893e88b02ecfcb44f2166f9c0b7f2a0d" |
@@ -81,6 +82,9 @@ python do_patch() { | |||
81 | bb.build.exec_func('patch_do_patch', d) | 82 | bb.build.exec_func('patch_do_patch', d) |
82 | } | 83 | } |
83 | 84 | ||
85 | #addtask zlibqat_patch after do_prepare_recipe_sysroot before patch_do_patch | ||
86 | #addtask do_zlibqat_patch after do_prepare_recipe_sysroot before do_configure | ||
87 | |||
84 | do_configure() { | 88 | do_configure() { |
85 | ./configure --prefix=${prefix} --shared --libdir=${libdir} | 89 | ./configure --prefix=${prefix} --shared --libdir=${libdir} |
86 | } | 90 | } |