diff options
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad')
9 files changed, 66 insertions, 197 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch deleted file mode 100644 index 5e6a1c05..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-ext-wayland-fix-meson-build-in-nxp-fork.patch +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | From 9e092d8976db034a2d6848d738c4f73cc001fd09 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
3 | Date: Sun, 26 Jan 2020 10:45:28 +0000 | ||
4 | Subject: [PATCH] ext/wayland: fix meson build in nxp fork | ||
5 | |||
6 | - Add Wayland protocols, which are not enabled in upstream | ||
7 | - Add missing compilation unit, which in NXP-specific | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
12 | |||
13 | --- | ||
14 | ext/wayland/meson.build | 24 ++++++++++++++++++++++++ | ||
15 | 1 file changed, 24 insertions(+) | ||
16 | |||
17 | diff --git a/ext/wayland/meson.build b/ext/wayland/meson.build | ||
18 | index 3c377eefb..98a7cb76f 100644 | ||
19 | --- a/ext/wayland/meson.build | ||
20 | +++ b/ext/wayland/meson.build | ||
21 | @@ -10,6 +10,11 @@ wl_sources = [ | ||
22 | |||
23 | libdrm_dep = dependency('libdrm', version: '>= 2.4.55', required:get_option('wayland')) | ||
24 | |||
25 | +imx_wl_sources = [ | ||
26 | + 'wlutils.c', | ||
27 | +] | ||
28 | +wl_sources += imx_wl_sources | ||
29 | + | ||
30 | if use_wayland | ||
31 | protocols_datadir = wl_protocol_dep.get_pkgconfig_variable('pkgdatadir') | ||
32 | |||
33 | @@ -21,6 +26,25 @@ if use_wayland | ||
34 | 'fullscreen-shell-unstable-v1-protocol.c', 'fullscreen-shell-unstable-v1-client-protocol.h'], | ||
35 | ['/stable/xdg-shell/xdg-shell.xml', 'xdg-shell-protocol.c', 'xdg-shell-client-protocol.h'], | ||
36 | ] | ||
37 | + | ||
38 | + imx_protocol_defs = [ | ||
39 | + [ | ||
40 | + '/unstable/alpha-compositing/alpha-compositing-unstable-v1.xml', | ||
41 | + 'alpha-compositing-unstable-v1-protocol.c', | ||
42 | + 'alpha-compositing-unstable-v1-client-protocol.h' | ||
43 | + ], | ||
44 | + ['/unstable/hdr10-metadata/hdr10-metadata-unstable-v1.xml', | ||
45 | + 'hdr10-metadata-unstable-v1-protocol.c', | ||
46 | + 'hdr10-metadata-unstable-v1-client-protocol.h' | ||
47 | + ], | ||
48 | + [ | ||
49 | + '/unstable/linux-explicit-synchronization/linux-explicit-synchronization-unstable-v1.xml', | ||
50 | + 'linux-explicit-synchronization-unstable-v1-protocol.c', | ||
51 | + 'linux-explicit-synchronization-unstable-v1-client-protocol.h' | ||
52 | + ], | ||
53 | + ] | ||
54 | + protocol_defs += imx_protocol_defs | ||
55 | + | ||
56 | protocols_files = [] | ||
57 | |||
58 | foreach protodef: protocol_defs | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-fix-maybe-uninitialized-warnings-when-compiling-with.patch index 7758300e..13a673cd 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-fix-maybe-uninitialized-warnings-when-compiling-with.patch | |||
@@ -1,18 +1,17 @@ | |||
1 | From e7914eb0baa3530a5075c0d3db7936ccddd8e3fe Mon Sep 17 00:00:00 2001 | 1 | From f08ab3ac2ce43ac91d3bf65b26f26436690f499b Mon Sep 17 00:00:00 2001 |
2 | From: Andre McCurdy <armccurdy@gmail.com> | 2 | From: Andre McCurdy <armccurdy@gmail.com> |
3 | Date: Tue, 26 Jan 2016 15:16:01 -0800 | 3 | Date: Tue, 26 Jan 2016 15:16:01 -0800 |
4 | Subject: [PATCH] fix maybe-uninitialized warnings when compiling with -Os | 4 | Subject: [PATCH 1/4] fix maybe-uninitialized warnings when compiling with -Os |
5 | 5 | ||
6 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
7 | 7 | ||
8 | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> | 8 | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> |
9 | |||
10 | --- | 9 | --- |
11 | gst-libs/gst/codecparsers/gstvc1parser.c | 2 +- | 10 | gst-libs/gst/codecparsers/gstvc1parser.c | 2 +- |
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | 11 | 1 file changed, 1 insertion(+), 1 deletion(-) |
13 | 12 | ||
14 | diff --git a/gst-libs/gst/codecparsers/gstvc1parser.c b/gst-libs/gst/codecparsers/gstvc1parser.c | 13 | diff --git a/gst-libs/gst/codecparsers/gstvc1parser.c b/gst-libs/gst/codecparsers/gstvc1parser.c |
15 | index ac579712d..1686f6081 100644 | 14 | index 2c60ced..e8226d8 100644 |
16 | --- a/gst-libs/gst/codecparsers/gstvc1parser.c | 15 | --- a/gst-libs/gst/codecparsers/gstvc1parser.c |
17 | +++ b/gst-libs/gst/codecparsers/gstvc1parser.c | 16 | +++ b/gst-libs/gst/codecparsers/gstvc1parser.c |
18 | @@ -1730,7 +1730,7 @@ gst_vc1_parse_sequence_layer (const guint8 * data, gsize size, | 17 | @@ -1730,7 +1730,7 @@ gst_vc1_parse_sequence_layer (const guint8 * data, gsize size, |
@@ -24,3 +23,6 @@ index ac579712d..1686f6081 100644 | |||
24 | guint8 structA[8] = { 0, }; | 23 | guint8 structA[8] = { 0, }; |
25 | guint8 structB[12] = { 0, }; | 24 | guint8 structB[12] = { 0, }; |
26 | GstBitReader br; | 25 | GstBitReader br; |
26 | -- | ||
27 | 2.28.0 | ||
28 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch deleted file mode 100644 index 4f9041dc..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | From 69cff1595f9e0014c582c6f540d69d86d5e824ff Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Tim-Philipp=20M=C3=BCller?= <tim@centricular.com> | ||
3 | Date: Fri, 18 Oct 2019 00:39:12 +0100 | ||
4 | Subject: [PATCH] meson: build gir even when cross-compiling if introspection | ||
5 | was enabled explicitly | ||
6 | |||
7 | This can be made to work in certain circumstances when | ||
8 | cross-compiling, so default to not building g-i stuff | ||
9 | when cross-compiling, but allow it if introspection was | ||
10 | enabled explicitly via -Dintrospection=enabled. | ||
11 | |||
12 | See gstreamer/gstreamer#454 and gstreamer/gstreamer#381. | ||
13 | |||
14 | Upstream-Status: Backport [97a4d0cd7de8cfbf983acc7e37ba2f8fb73c3e19] | ||
15 | |||
16 | Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org> | ||
17 | |||
18 | --- | ||
19 | meson.build | 2 +- | ||
20 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/meson.build b/meson.build | ||
23 | index 2b492faea..bea89b23d 100644 | ||
24 | --- a/meson.build | ||
25 | +++ b/meson.build | ||
26 | @@ -405,7 +405,7 @@ python3 = import('python').find_installation() | ||
27 | |||
28 | gir = find_program('g-ir-scanner', required : get_option('introspection')) | ||
29 | gnome = import('gnome') | ||
30 | -build_gir = gir.found() and not meson.is_cross_build() | ||
31 | +build_gir = gir.found() and (not meson.is_cross_build() or get_option('introspection').enabled()) | ||
32 | gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' + \ | ||
33 | 'g_setenv("GST_REGISTRY_1.0", "@0@", TRUE);'.format(meson.current_build_dir() + '/gir_empty_registry.reg') + \ | ||
34 | 'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \ | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch deleted file mode 100644 index 525f4a45..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.4.x.patch +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | From a4df38174d33dc1e620ea535e16cac406ff59da2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Nicola Murino <nicola.murino@gmail.com> | ||
3 | Date: Fri, 31 Jul 2020 23:38:56 +0200 | ||
4 | Subject: [PATCH] opencv: allow compilation against 4.4.x | ||
5 | |||
6 | Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1482> | ||
7 | |||
8 | Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/commit/8544f3928ea46d2da3f27dc65576e8baf42a46d] | ||
9 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
10 | |||
11 | --- | ||
12 | ext/opencv/meson.build | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build | ||
16 | index a26403482..b3270e540 100644 | ||
17 | --- a/ext/opencv/meson.build | ||
18 | +++ b/ext/opencv/meson.build | ||
19 | @@ -65,7 +65,7 @@ if opencv_found | ||
20 | endif | ||
21 | endforeach | ||
22 | else | ||
23 | - opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.2.0'], required : false) | ||
24 | + opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.5.0'], required : false) | ||
25 | opencv_found = opencv_dep.found() | ||
26 | if opencv_found | ||
27 | foreach h : libopencv4_headers | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch deleted file mode 100644 index 5b8e0159..00000000 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | From 54c700f9721ef218188803b48acae46e885626ee Mon Sep 17 00:00:00 2001 | ||
2 | From: "Jan Alexander Steffens (heftig)" <jan.steffens@ltnglobal.com> | ||
3 | Date: Sat, 9 May 2020 19:59:46 +0200 | ||
4 | Subject: [PATCH] vulkan: Drop use of VK_RESULT_BEGIN_RANGE | ||
5 | |||
6 | This was removed in Vulkan 1.2.140. | ||
7 | |||
8 | > Shortly after 2020-04-24, we will be removing the automatically | ||
9 | > generated `VK_*_BEGIN_RANGE`, `VK_*_END_RANGE`, and `VK_*_RANGE_SIZE` | ||
10 | > tokens from the Vulkan headers. These tokens are currently defined for | ||
11 | > some enumerated types, but are explicitly not part of the Vulkan API. | ||
12 | > They existed only to support some Vulkan implementation internals, | ||
13 | > which no longer require them. We will be accepting comments on this | ||
14 | > topic in [#1230], but we strongly suggest any external projects using | ||
15 | > these tokens immediately migrate away from them. | ||
16 | |||
17 | [#1230]: https://github.com/KhronosGroup/Vulkan-Docs/issues/1230 | ||
18 | |||
19 | Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1603> | ||
20 | |||
21 | Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/commit/17850d7e87af93c6bd181d7c25903478c2254fa6] | ||
22 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | ||
23 | --- | ||
24 | ext/vulkan/vkerror.c | 4 +--- | ||
25 | 1 file changed, 1 insertion(+), 3 deletions(-) | ||
26 | |||
27 | diff --git a/ext/vulkan/vkerror.c b/ext/vulkan/vkerror.c | ||
28 | index 3fec27e4d..c91589d9b 100644 | ||
29 | --- a/ext/vulkan/vkerror.c | ||
30 | +++ b/ext/vulkan/vkerror.c | ||
31 | @@ -27,7 +27,7 @@ | ||
32 | #include "vkerror.h" | ||
33 | |||
34 | /* *INDENT-OFF* */ | ||
35 | -static const struct | ||
36 | +static const struct | ||
37 | { | ||
38 | VkResult result; | ||
39 | const char *str; | ||
40 | @@ -63,8 +63,6 @@ _vk_result_to_string (VkResult result) | ||
41 | |||
42 | if (result >= 0) | ||
43 | return NULL; | ||
44 | - if (result < VK_RESULT_BEGIN_RANGE) | ||
45 | - return "Unknown Error"; | ||
46 | |||
47 | for (i = 0; i < G_N_ELEMENTS (vk_result_string_map); i++) { | ||
48 | if (result == vk_result_string_map[i].result) | ||
49 | -- | ||
50 | 2.17.1 | ||
51 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/avoid-including-sys-poll.h-directly.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-avoid-including-sys-poll.h-directly.patch index da2dd8bf..ead6897f 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/avoid-including-sys-poll.h-directly.patch +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-avoid-including-sys-poll.h-directly.patch | |||
@@ -1,20 +1,19 @@ | |||
1 | From 05f9a7a9025cb1c6a5592ba998ab95d565f9c76f Mon Sep 17 00:00:00 2001 | 1 | From 3b05e91720c10fcf6e0e408595b7217f6fa145c2 Mon Sep 17 00:00:00 2001 |
2 | From: Andre McCurdy <armccurdy@gmail.com> | 2 | From: Andre McCurdy <armccurdy@gmail.com> |
3 | Date: Wed, 3 Feb 2016 18:05:41 -0800 | 3 | Date: Wed, 3 Feb 2016 18:05:41 -0800 |
4 | Subject: [PATCH] avoid including <sys/poll.h> directly | 4 | Subject: [PATCH 2/4] avoid including <sys/poll.h> directly |
5 | 5 | ||
6 | musl libc generates warnings if <sys/poll.h> is included directly. | 6 | musl libc generates warnings if <sys/poll.h> is included directly. |
7 | 7 | ||
8 | Upstream-Status: Pending | 8 | Upstream-Status: Pending |
9 | 9 | ||
10 | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> | 10 | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> |
11 | |||
12 | --- | 11 | --- |
13 | sys/dvb/gstdvbsrc.c | 2 +- | 12 | sys/dvb/gstdvbsrc.c | 2 +- |
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 13 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 14 | ||
16 | diff --git a/sys/dvb/gstdvbsrc.c b/sys/dvb/gstdvbsrc.c | 15 | diff --git a/sys/dvb/gstdvbsrc.c b/sys/dvb/gstdvbsrc.c |
17 | index bd07369c3..ebfbe4947 100644 | 16 | index ca6b92a..b2772db 100644 |
18 | --- a/sys/dvb/gstdvbsrc.c | 17 | --- a/sys/dvb/gstdvbsrc.c |
19 | +++ b/sys/dvb/gstdvbsrc.c | 18 | +++ b/sys/dvb/gstdvbsrc.c |
20 | @@ -97,7 +97,7 @@ | 19 | @@ -97,7 +97,7 @@ |
@@ -26,3 +25,6 @@ index bd07369c3..ebfbe4947 100644 | |||
26 | #include <fcntl.h> | 25 | #include <fcntl.h> |
27 | #include <errno.h> | 26 | #include <errno.h> |
28 | #include <stdio.h> | 27 | #include <stdio.h> |
28 | -- | ||
29 | 2.28.0 | ||
30 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/ensure-valid-sentinels-for-gst_structure_get-etc.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0003-ensure-valid-sentinals-for-gst_structure_get-etc.patch index c25a11e9..88fbc40d 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/ensure-valid-sentinels-for-gst_structure_get-etc.patch +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0003-ensure-valid-sentinals-for-gst_structure_get-etc.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From f9a8b71897af39640894915a5f202d0027124f57 Mon Sep 17 00:00:00 2001 | 1 | From 5ed27de9f662fe063b8b3d5d4335aa64cd4718c9 Mon Sep 17 00:00:00 2001 |
2 | From: Andre McCurdy <armccurdy@gmail.com> | 2 | From: Andre McCurdy <armccurdy@gmail.com> |
3 | Date: Tue, 9 Feb 2016 14:00:00 -0800 | 3 | Date: Tue, 9 Feb 2016 14:00:00 -0800 |
4 | Subject: [PATCH] ensure valid sentinals for gst_structure_get() etc | 4 | Subject: [PATCH 3/4] ensure valid sentinals for gst_structure_get() etc |
5 | 5 | ||
6 | For GStreamer functions declared with G_GNUC_NULL_TERMINATED, | 6 | For GStreamer functions declared with G_GNUC_NULL_TERMINATED, |
7 | ie __attribute__((__sentinel__)), gcc will generate a warning if the | 7 | ie __attribute__((__sentinel__)), gcc will generate a warning if the |
@@ -17,7 +17,6 @@ without an explicit cast to a pointer type. | |||
17 | Upstream-Status: Pending | 17 | Upstream-Status: Pending |
18 | 18 | ||
19 | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> | 19 | Signed-off-by: Andre McCurdy <armccurdy@gmail.com> |
20 | |||
21 | --- | 20 | --- |
22 | sys/decklink/gstdecklink.cpp | 10 +++++----- | 21 | sys/decklink/gstdecklink.cpp | 10 +++++----- |
23 | sys/decklink/gstdecklinkaudiosrc.cpp | 2 +- | 22 | sys/decklink/gstdecklinkaudiosrc.cpp | 2 +- |
@@ -25,19 +24,19 @@ Signed-off-by: Andre McCurdy <armccurdy@gmail.com> | |||
25 | 3 files changed, 7 insertions(+), 7 deletions(-) | 24 | 3 files changed, 7 insertions(+), 7 deletions(-) |
26 | 25 | ||
27 | diff --git a/sys/decklink/gstdecklink.cpp b/sys/decklink/gstdecklink.cpp | 26 | diff --git a/sys/decklink/gstdecklink.cpp b/sys/decklink/gstdecklink.cpp |
28 | index 464b0de9d..9fb7246d3 100644 | 27 | index 4dac7e1..43762ce 100644 |
29 | --- a/sys/decklink/gstdecklink.cpp | 28 | --- a/sys/decklink/gstdecklink.cpp |
30 | +++ b/sys/decklink/gstdecklink.cpp | 29 | +++ b/sys/decklink/gstdecklink.cpp |
31 | @@ -617,7 +617,7 @@ gst_decklink_mode_get_structure (GstDecklinkModeEnum e, BMDPixelFormat f, | 30 | @@ -674,7 +674,7 @@ gst_decklink_mode_get_generic_structure (GstDecklinkModeEnum e) |
32 | "pixel-aspect-ratio", GST_TYPE_FRACTION, mode->par_n, mode->par_d, | 31 | "pixel-aspect-ratio", GST_TYPE_FRACTION, mode->par_n, mode->par_d, |
33 | "interlace-mode", G_TYPE_STRING, | 32 | "interlace-mode", G_TYPE_STRING, |
34 | mode->interlaced ? "interleaved" : "progressive", | 33 | mode->interlaced ? "interleaved" : "progressive", |
35 | - "framerate", GST_TYPE_FRACTION, mode->fps_n, mode->fps_d, NULL); | 34 | - "framerate", GST_TYPE_FRACTION, mode->fps_n, mode->fps_d, NULL); |
36 | + "framerate", GST_TYPE_FRACTION, mode->fps_n, mode->fps_d, (void*)NULL); | 35 | + "framerate", GST_TYPE_FRACTION, mode->fps_n, mode->fps_d, (void*)NULL); |
37 | 36 | ||
38 | if (input && mode->interlaced) { | 37 | return s; |
39 | if (mode->tff) | 38 | } |
40 | @@ -632,16 +632,16 @@ gst_decklink_mode_get_structure (GstDecklinkModeEnum e, BMDPixelFormat f, | 39 | @@ -699,16 +699,16 @@ gst_decklink_mode_get_structure (GstDecklinkModeEnum e, BMDPixelFormat f, |
41 | case bmdFormat8BitYUV: /* '2vuy' */ | 40 | case bmdFormat8BitYUV: /* '2vuy' */ |
42 | gst_structure_set (s, "format", G_TYPE_STRING, "UYVY", | 41 | gst_structure_set (s, "format", G_TYPE_STRING, "UYVY", |
43 | "colorimetry", G_TYPE_STRING, mode->colorimetry, | 42 | "colorimetry", G_TYPE_STRING, mode->colorimetry, |
@@ -59,7 +58,7 @@ index 464b0de9d..9fb7246d3 100644 | |||
59 | case bmdFormat10BitRGB: /* 'r210' Big-endian RGB 10-bit per component with SMPTE video levels (64-960). Packed as 2:10:10:10 */ | 58 | case bmdFormat10BitRGB: /* 'r210' Big-endian RGB 10-bit per component with SMPTE video levels (64-960). Packed as 2:10:10:10 */ |
60 | case bmdFormat12BitRGB: /* 'R12B' Big-endian RGB 12-bit per component with full range (0-4095). Packed as 12-bit per component */ | 59 | case bmdFormat12BitRGB: /* 'R12B' Big-endian RGB 12-bit per component with full range (0-4095). Packed as 12-bit per component */ |
61 | diff --git a/sys/decklink/gstdecklinkaudiosrc.cpp b/sys/decklink/gstdecklinkaudiosrc.cpp | 60 | diff --git a/sys/decklink/gstdecklinkaudiosrc.cpp b/sys/decklink/gstdecklinkaudiosrc.cpp |
62 | index 2fef934c8..c47229abf 100644 | 61 | index 2fef934..c47229a 100644 |
63 | --- a/sys/decklink/gstdecklinkaudiosrc.cpp | 62 | --- a/sys/decklink/gstdecklinkaudiosrc.cpp |
64 | +++ b/sys/decklink/gstdecklinkaudiosrc.cpp | 63 | +++ b/sys/decklink/gstdecklinkaudiosrc.cpp |
65 | @@ -379,7 +379,7 @@ gst_decklink_audio_src_start (GstDecklinkAudioSrc * self) | 64 | @@ -379,7 +379,7 @@ gst_decklink_audio_src_start (GstDecklinkAudioSrc * self) |
@@ -72,10 +71,10 @@ index 2fef934c8..c47229abf 100644 | |||
72 | 71 | ||
73 | switch (vconn) { | 72 | switch (vconn) { |
74 | diff --git a/sys/decklink/gstdecklinkvideosink.cpp b/sys/decklink/gstdecklinkvideosink.cpp | 73 | diff --git a/sys/decklink/gstdecklinkvideosink.cpp b/sys/decklink/gstdecklinkvideosink.cpp |
75 | index 7aea3f7a2..4864508bb 100644 | 74 | index e3a6775..f1a5aae 100644 |
76 | --- a/sys/decklink/gstdecklinkvideosink.cpp | 75 | --- a/sys/decklink/gstdecklinkvideosink.cpp |
77 | +++ b/sys/decklink/gstdecklinkvideosink.cpp | 76 | +++ b/sys/decklink/gstdecklinkvideosink.cpp |
78 | @@ -285,7 +285,7 @@ reset_framerate (GstCapsFeatures * features, GstStructure * structure, | 77 | @@ -286,7 +286,7 @@ reset_framerate (GstCapsFeatures * features, GstStructure * structure, |
79 | gpointer user_data) | 78 | gpointer user_data) |
80 | { | 79 | { |
81 | gst_structure_set (structure, "framerate", GST_TYPE_FRACTION_RANGE, 0, 1, | 80 | gst_structure_set (structure, "framerate", GST_TYPE_FRACTION_RANGE, 0, 1, |
@@ -84,3 +83,6 @@ index 7aea3f7a2..4864508bb 100644 | |||
84 | 83 | ||
85 | return TRUE; | 84 | return TRUE; |
86 | } | 85 | } |
86 | -- | ||
87 | 2.28.0 | ||
88 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch index dc3a8c69..b8167090 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch | |||
@@ -1,23 +1,22 @@ | |||
1 | From 387886b05f4ae0de9b7faf1f9ca66040d38d19ee Mon Sep 17 00:00:00 2001 | 1 | From f19ff66640f2f472c4e9d9055253032d34e125c6 Mon Sep 17 00:00:00 2001 |
2 | From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 2 | From: Andrey Zhizhikin <andrey.z@gmail.com> |
3 | Date: Sun, 26 Jan 2020 19:55:06 +0000 | 3 | Date: Mon, 27 Jan 2020 10:22:35 +0000 |
4 | Subject: [PATCH] opencv: resolve missing opencv data dir in yocto build | 4 | Subject: [PATCH 4/4] opencv: resolve missing opencv data dir in yocto build |
5 | 5 | ||
6 | When Yocto build is performed, opencv searches for data dir using simple | 6 | When Yocto build is performed, opencv searches for data dir using simple |
7 | test command, and this fails because pkg-config provides an absolute | 7 | 'test' command, this fails because pkg-config provides an absolute |
8 | path on the target which needs to be prepended by PKG_CONFIG_SYSROOT_DIR | 8 | path on the target which needs to be prepended by PKG_CONFIG_SYSROOT_DIR |
9 | in order for the 'test' utility to pick up the absolute path. | 9 | in order for the 'test' utility to pick up the absolute path. |
10 | 10 | ||
11 | Upstream-Status: Inappropriate [OE-specific] | 11 | Upstream-Status: Inappropriate [OE-specific] |
12 | 12 | ||
13 | Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> | 13 | Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> |
14 | |||
15 | --- | 14 | --- |
16 | ext/opencv/meson.build | 7 ++++--- | 15 | ext/opencv/meson.build | 7 ++++--- |
17 | 1 file changed, 4 insertions(+), 3 deletions(-) | 16 | 1 file changed, 4 insertions(+), 3 deletions(-) |
18 | 17 | ||
19 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build | 18 | diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build |
20 | index f38b55dfe..a26403482 100644 | 19 | index 0b0b3fc..0ed3344 100644 |
21 | --- a/ext/opencv/meson.build | 20 | --- a/ext/opencv/meson.build |
22 | +++ b/ext/opencv/meson.build | 21 | +++ b/ext/opencv/meson.build |
23 | @@ -78,20 +78,21 @@ else | 22 | @@ -78,20 +78,21 @@ else |
@@ -45,3 +44,6 @@ index f38b55dfe..a26403482 100644 | |||
45 | if r.returncode() == 0 | 44 | if r.returncode() == 0 |
46 | gstopencv_cargs += '-DOPENCV_PATH_NAME="opencv4"' | 45 | gstopencv_cargs += '-DOPENCV_PATH_NAME="opencv4"' |
47 | else | 46 | else |
47 | -- | ||
48 | 2.28.0 | ||
49 | |||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0005-msdk-fix-includedir-path.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0005-msdk-fix-includedir-path.patch new file mode 100644 index 00000000..cb3bb7d3 --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0005-msdk-fix-includedir-path.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 1f00d5026118ebd48e4ccf83d32d67155c4e7f60 Mon Sep 17 00:00:00 2001 | ||
2 | From: Naveen Saini <naveen.kumar.saini@intel.com> | ||
3 | Date: Wed, 30 Dec 2020 16:37:47 +0800 | ||
4 | Subject: [PATCH] msdk: fix includedir path | ||
5 | |||
6 | In cross compilation, need to prepend PKG_CONFIG_SYSROOT_DIR to the dir path. | ||
7 | |||
8 | Upstream-Status: Inappropriate [OE-specific] | ||
9 | |||
10 | Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com> | ||
11 | --- | ||
12 | sys/msdk/meson.build | 2 ++ | ||
13 | 1 file changed, 2 insertions(+) | ||
14 | |||
15 | diff --git a/sys/msdk/meson.build b/sys/msdk/meson.build | ||
16 | index 6346c9451..068f38548 100644 | ||
17 | --- a/sys/msdk/meson.build | ||
18 | +++ b/sys/msdk/meson.build | ||
19 | @@ -40,7 +40,9 @@ endif | ||
20 | |||
21 | mfx_dep = dependency('libmfx', required: false) | ||
22 | if mfx_dep.found() | ||
23 | + pkgconf_sysroot = run_command(python3, '-c', 'import os; print(os.environ.get("PKG_CONFIG_SYSROOT_DIR"))').stdout().strip() | ||
24 | mfx_incdir = mfx_dep.get_pkgconfig_variable('includedir') | ||
25 | + mfx_incdir = pkgconf_sysroot + mfx_incdir | ||
26 | mfx_inc = [] | ||
27 | else | ||
28 | # Old versions of MediaSDK don't provide a pkg-config file | ||
29 | -- | ||
30 | 2.17.1 | ||
31 | |||