summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx_6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx_6.6.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.6.bb23
1 files changed, 9 insertions, 14 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.6.bb b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
index d75e24f7..a955ae1c 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.6.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.6.bb
@@ -39,17 +39,12 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41 41
42# $ git log --oneline --no-merges v6.6.23.. ^mainline/linux-6.6.y ^NXP/lf-6.6.y 42# $ git log --oneline --no-merges v6.6.34.. ^mainline/linux-6.6.y ^NXP/lf-6.6.y
43# - 4d8a7fb526c1 imx8mp: Remove obsolete device tree file 43# - 3fb57e773e55 tty: vt: conmakehash: Don't mention the full path of the input in output
44# - e420d14b057f MLK-25922-4 arm64: dts: imx93: add lpspi support 44# - d1198b88bc1b Revert "dmaengine: fsl-edma: add address for channel mux register in fsl_edma_chan"
45# - 965390eee531 Revert "dmaengine: fsl-edma: add address for channel mux register in fsl_edma_chan" 45# - 717fee4a9cf7 Revert "dmaengine: fsl-edma: add i.MX8ULP edma support"
46# - a1553c4e0862 Revert "dmaengine: fsl-edma: add i.MX8ULP edma support" 46# - 74ef72069927 Revert "dmaengine: fsl-edma: clean up unused "fsl,imx8qm-adma" compatible string"
47# - 652e34468562 Revert "dmaengine: fsl-edma: clean up unused "fsl,imx8qm-adma" compatible string" 47# - b54c6ea17058 Revert "dmaengine: fsl-edma: change the memory access from local into remote mode in i.MX 8QM"
48# - f4114b5ea07c Revert "dmaengine: fsl-edma: change the memory access from local into remote mode in i.MX 8QM"
49# - 97e602775143 Revert "arm64: dts: imx8-ss-conn: fix usdhc wrong lpcg clock order"
50# - dd280fd310dd arm64: imx_v8_defconfig: Enable CONFIG_GPIO_VF610
51# - 7a31ed76b4ee drm/imx: lcdifv3: Fix videomode settings
52# - fb5da09f0eae i2c: imx: Remove unnecessary clock reconfiguration
53# 48#
54# NOTE to upgraders: 49# NOTE to upgraders:
55# This recipe should NOT collect individual patches, they should be applied to 50# This recipe should NOT collect individual patches, they should be applied to
@@ -59,16 +54,16 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
59 54
60require linux-imx.inc 55require linux-imx.inc
61 56
62KBRANCH = "6.6-2.0.x-imx" 57KBRANCH = "6.6-2.1.x-imx"
63SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 58SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
64SRCREV = "d023c381fa6161a7af966abaad8e7d9a997f07e7" 59SRCREV = "096cd0432b03805f49c86684dafb9ced4511a714"
65 60
66# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 61# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
67# required by kernel-yocto.bbclass. 62# required by kernel-yocto.bbclass.
68# 63#
69# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 64# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
70# should be updated once patchlevel is merged. 65# should be updated once patchlevel is merged.
71LINUX_VERSION = "6.6.51" 66LINUX_VERSION = "6.6.54"
72 67
73KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig" 68KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v7_defconfig"
74KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig" 69KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v7_defconfig"