summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorBenjamin Szőke <egyszeregy@freemail.hu>2024-09-28 15:43:08 +0200
committerGitHub <noreply@github.com>2024-09-28 15:43:08 +0200
commit39d58dfc62163d8909b774d29ed8fbb17d25ccd4 (patch)
treebf83bb986f12458824db1aa42f860fd1695c792f /recipes-kernel
parent64ec836a179d1cd95196a3315cd8550b78c25e9e (diff)
downloadmeta-freescale-39d58dfc62163d8909b774d29ed8fbb17d25ccd4.tar.gz
linux-fslc-lts: restore LTS v6.1
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-fslc-lts_6.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc-lts_6.1.bb b/recipes-kernel/linux/linux-fslc-lts_6.1.bb
new file mode 100644
index 00000000..8e1bab4b
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-lts_6.1.bb
@@ -0,0 +1,41 @@
1# Copyright (C) 2012-2019 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3#
4# SPDX-License-Identifier: MIT
5#
6
7SUMMARY = "FSL Community BSP Linux LTS based kernel with backported features and fixes"
8DESCRIPTION = "Linux kernel based on LTS kernel used by FSL Community BSP in order to \
9provide support for some backported features and fixes, or because it was applied in upstream \
10and will not become part of a LTS version, or because it is not applicable for \
11upstreaming in any form."
12
13require linux-imx.inc
14
15KERNEL_DEVICETREE_32BIT_COMPATIBILITY_UPDATE = "1"
16
17SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
18
19# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
20# required by kernel-yocto.bbclass.
21#
22# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
23# should be updated once patchlevel is merged.
24LINUX_VERSION = "6.1.72"
25
26KBRANCH = "6.1.x+fslc"
27SRCREV = "b80c9dede70132da3ae7feb949fe0803aad3db24"
28
29KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
30KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
31KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
32KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig"
33KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v6_v7_defconfig"
34KBUILD_DEFCONFIG:mx8-generic-bsp = "defconfig"
35KBUILD_DEFCONFIG:mx9-generic-bsp = "defconfig"
36KBUILD_DEFCONFIG:mxs-generic-bsp = "mxs_defconfig"
37KBUILD_DEFCONFIG:vf-generic-bsp = "imx_v6_v7_defconfig"
38
39LOCALVERSION = "-fslc"
40
41COMPATIBLE_MACHINE = "(imx-generic-bsp)"