diff options
author | Andrej Valek <andrej.v@skyrain.eu> | 2024-12-03 15:54:06 +0100 |
---|---|---|
committer | Andrej Valek <andrej.v@skyrain.eu> | 2024-12-03 15:54:06 +0100 |
commit | ccf9a1bcea6321cdfb760726aacc7759afbc6710 (patch) | |
tree | 71c3942304ddcf7dcf52d07942a2176dc79ad681 /recipes-bsp | |
parent | 9e33c7eb91fdf2331ab338ac5e4c83d12504c5d6 (diff) | |
download | meta-freescale-ccf9a1bcea6321cdfb760726aacc7759afbc6710.tar.gz |
feat(regex): use explicitly regex mark for regexs
This should fix errors like this:
| Parsing recipes...WARNING: /home/project/build/../meta-freescale/recipes-multimedia/imx-codec/imx-codec_4.8.3.bb: /home/project/build/../meta-freescale/recipes-multimedia/imx-codec/imx-codec_4.8.3.bb:63: SyntaxWarning: invalid escape sequence '\.'
| do_split_packages(d, codecdir, '^lib_([^_]*).*_arm.*_elinux\.so\..*',
Signed-off-by: Andrej Valek <andrej.v@skyrain.eu>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/firmware-imx/firmware-imx_8.26.bb | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx_8.26.bb b/recipes-bsp/firmware-imx/firmware-imx_8.26.bb index a4e17c99..7bac8106 100644 --- a/recipes-bsp/firmware-imx/firmware-imx_8.26.bb +++ b/recipes-bsp/firmware-imx/firmware-imx_8.26.bb | |||
@@ -102,14 +102,14 @@ python populate_packages:prepend() { | |||
102 | 102 | ||
103 | 103 | ||
104 | easrcdir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/easrc', d) | 104 | easrcdir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/easrc', d) |
105 | do_split_packages(d, easrcdir, '^easrc-([^_]*).*\.bin', | 105 | do_split_packages(d, easrcdir, r'^easrc-([^_]*).*\.bin', |
106 | output_pattern='firmware-imx-easrc-%s', | 106 | output_pattern='firmware-imx-easrc-%s', |
107 | description='Freescale IMX EASRC Firmware [%s]', | 107 | description='Freescale IMX EASRC Firmware [%s]', |
108 | extra_depends='', | 108 | extra_depends='', |
109 | prepend=True) | 109 | prepend=True) |
110 | 110 | ||
111 | vpudir = bb.data.expand('${nonarch_base_libdir}/firmware/vpu', d) | 111 | vpudir = bb.data.expand('${nonarch_base_libdir}/firmware/vpu', d) |
112 | do_split_packages(d, vpudir, '^vpu_fw_([^_]*).*\.bin', | 112 | do_split_packages(d, vpudir, r'^vpu_fw_([^_]*).*\.bin', |
113 | output_pattern='firmware-imx-vpu-%s', | 113 | output_pattern='firmware-imx-vpu-%s', |
114 | description='Freescale IMX VPU Firmware [%s]', | 114 | description='Freescale IMX VPU Firmware [%s]', |
115 | hook=coda_vpu_links, | 115 | hook=coda_vpu_links, |
@@ -117,21 +117,21 @@ python populate_packages:prepend() { | |||
117 | prepend=True) | 117 | prepend=True) |
118 | 118 | ||
119 | sdmadir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/sdma', d) | 119 | sdmadir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/sdma', d) |
120 | do_split_packages(d, sdmadir, '^sdma-([^-]*).*\.bin', | 120 | do_split_packages(d, sdmadir, r'^sdma-([^-]*).*\.bin', |
121 | output_pattern='firmware-imx-sdma-%s', | 121 | output_pattern='firmware-imx-sdma-%s', |
122 | description='Freescale IMX SDMA Firmware [%s]', | 122 | description='Freescale IMX SDMA Firmware [%s]', |
123 | extra_depends='', | 123 | extra_depends='', |
124 | prepend=True) | 124 | prepend=True) |
125 | 125 | ||
126 | xcvrdir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/xcvr', d) | 126 | xcvrdir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/xcvr', d) |
127 | do_split_packages(d, xcvrdir, '^xcvr-([^_]*).*\.bin', | 127 | do_split_packages(d, xcvrdir, r'^xcvr-([^_]*).*\.bin', |
128 | output_pattern='firmware-imx-xcvr-%s', | 128 | output_pattern='firmware-imx-xcvr-%s', |
129 | description='Freescale IMX XCVR Firmware [%s]', | 129 | description='Freescale IMX XCVR Firmware [%s]', |
130 | extra_depends='', | 130 | extra_depends='', |
131 | prepend=True) | 131 | prepend=True) |
132 | 132 | ||
133 | xuvidir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/xuvi', d) | 133 | xuvidir = bb.data.expand('${nonarch_base_libdir}/firmware/imx/xuvi', d) |
134 | do_split_packages(d, xuvidir, '^vpu_fw_([^_]*).*\.bin', | 134 | do_split_packages(d, xuvidir, r'^vpu_fw_([^_]*).*\.bin', |
135 | output_pattern='firmware-imx-xuvi-%s', | 135 | output_pattern='firmware-imx-xuvi-%s', |
136 | description='Freescale IMX XUVI Firmware [%s]', | 136 | description='Freescale IMX XUVI Firmware [%s]', |
137 | extra_depends='', | 137 | extra_depends='', |