summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-mkimage
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2024-08-19 10:28:08 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2024-08-20 12:36:33 -0700
commit2db7047ba40efed4d9e7c86c63d71158d974e297 (patch)
tree1e130202ff977c3a061b661bda1c3bca6fa179bc /recipes-bsp/imx-mkimage
parent605af4c9ae5e2ffb5d29ffc72fe4c3d75e435b4c (diff)
downloadmeta-freescale-2db7047ba40efed4d9e7c86c63d71158d974e297.tar.gz
imx-boot: Fix 8M multi-config build problems
Building in the NXP layer meta-imx with the latest imx-boot recipe, the dtb is not found during mkimage build: ``` | NOTE: building iMX8MP - TEE=tee.bin-stmm flash_evk_stmm_capsule | dtc -@ -I dts -O dtb -o signature.dtbo signature.dts | fdtoverlay -i imx8mp-evk.dtb -o imx8mp-evk.dtb signature.dtbo | Couldn't open blob from 'imx8mp-evk.dtb': No such file or directory ``` The problem is the recipe does now copy the dtb from u-boot-imx with a config-adorned name, e.g., imx8mp-evk.dtb-sd, but mkimage is still expecting imx8mp-evk.dtb. Add a link for compatibility. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp/imx-mkimage')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index 3f5b2c65..7013d6d1 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -101,17 +101,19 @@ compile_mx8m() {
101 101
102 if [ "x${UBOOT_SIGN_ENABLE}" = "x1" ] ; then 102 if [ "x${UBOOT_SIGN_ENABLE}" = "x1" ] ; then
103 # Use DTB binary patched with signature node 103 # Use DTB binary patched with signature node
104 cp ${DEPLOY_DIR_IMAGE}/${UBOOT_DTB_BINARY} ${BOOT_STAGING}/${UBOOT_DTB_NAME_EXTRA} 104 cp ${DEPLOY_DIR_IMAGE}/${UBOOT_DTB_BINARY} ${BOOT_STAGING}/${UBOOT_DTB_NAME_EXTRA}
105 else 105 else
106 cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${UBOOT_DTB_NAME_EXTRA} ${BOOT_STAGING} 106 cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/${UBOOT_DTB_NAME_EXTRA} \
107 ${BOOT_STAGING}
107 fi 108 fi
109 ln -sf ${UBOOT_DTB_NAME_EXTRA} ${BOOT_STAGING}/${UBOOT_DTB_NAME}
108 110
109 cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \ 111 cp ${DEPLOY_DIR_IMAGE}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG_EXTRA} \
110 ${BOOT_STAGING}/u-boot-nodtb.bin 112 ${BOOT_STAGING}/u-boot-nodtb.bin
111 113
112 cp ${DEPLOY_DIR_IMAGE}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin 114 cp ${DEPLOY_DIR_IMAGE}/${ATF_MACHINE_NAME} ${BOOT_STAGING}/bl31.bin
113 115
114 cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME_EXTRA} ${BOOT_STAGING}/u-boot.bin 116 cp ${DEPLOY_DIR_IMAGE}/${UBOOT_NAME_EXTRA} ${BOOT_STAGING}/u-boot.bin
115 117
116} 118}
117 119