summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-06-13 08:37:47 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2024-06-13 08:39:45 +0200
commitdf6ff365d3292c9874b055b55e2378ee8307c1fd (patch)
treedc9fd8aa24c1baa6989b85c0824ad48529c510e1
parent29b29781f20395f6c204a713715fda5fe280301b (diff)
downloadmeta-freescale-df6ff365d3292c9874b055b55e2378ee8307c1fd.tar.gz
imx-vpu-hantro: fix compile time error
GCC-14 set more warnings to errors, demote the ones which trigger to a warning. Fixes: | ../../source/h264high/h264decapi.c:1803:22: error: assignment to 'const u8 *' {aka 'const unsigned char *'} from incompatible pointer type 'u32 *' {aka 'unsigned int *'} [-Wincompatible-pointer-types] | 1803 | ref_data = ref.virtual_address; | ../../source/h264high/h264decapi.c:2086:22: error: assignment to 'const u8 *' {aka 'const unsigned char *'} from incompatible pointer type 'u32 *' {aka 'unsigned int *'} [-Wincompatible-pointer-types] | 2086 | ref_data = ref.virtual_address; Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb
index b486fda5..2a35f9ac 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.32.0.bb
@@ -17,6 +17,12 @@ PLATFORM:mx8mm-nxp-bsp = "IMX8MM"
17PLATFORM:mx8mq-nxp-bsp = "IMX8MQ" 17PLATFORM:mx8mq-nxp-bsp = "IMX8MQ"
18PLATFORM:mx8mp-nxp-bsp = "IMX8MP" 18PLATFORM:mx8mp-nxp-bsp = "IMX8MP"
19 19
20#| ../../source/h264high/h264decapi.c:1803:22: error: assignment to 'const u8 *' {aka 'const unsigned char *'} from incompatible pointer type 'u32 *' {aka 'unsigned int *'} [-Wincompatible-pointer-types]
21#| 1803 | ref_data = ref.virtual_address;
22#| ../../source/h264high/h264decapi.c:2086:22: error: assignment to 'const u8 *' {aka 'const unsigned char *'} from incompatible pointer type 'u32 *' {aka 'unsigned int *'} [-Wincompatible-pointer-types]
23#| 2086 | ref_data = ref.virtual_address;
24
25CFLAGS += " -Wno-error=incompatible-pointer-types"
20EXTRA_OEMAKE = " \ 26EXTRA_OEMAKE = " \
21 CROSS_COMPILE="${HOST_PREFIX}" \ 27 CROSS_COMPILE="${HOST_PREFIX}" \
22 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \ 28 SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" \