diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2025-04-15 17:47:24 -0300 |
---|---|---|
committer | GitHub <noreply@github.com> | 2025-04-15 17:47:24 -0300 |
commit | b2b2621827a93e4fb7efbd71f0005b91a710edce (patch) | |
tree | 0b93cc916d67162cc6de18131401a5ae7ed8d4e5 | |
parent | 38479d3fcc396c383b09b5c8eaa790b6788d5008 (diff) | |
parent | 16071e42d0b5e66a31d89eb296e9239da051b663 (diff) | |
download | meta-freescale-b2b2621827a93e4fb7efbd71f0005b91a710edce.tar.gz |
Merge pull request #2193 from OSSystems/topic/u-boot-update
u-boot-imx: Update source revision
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc | 8 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-imx_2024.04.bb | 4 |
2 files changed, 7 insertions, 5 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc b/recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc index 39ac4135..01e3bbca 100644 --- a/recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc +++ b/recipes-bsp/u-boot/u-boot-imx-common_2024.04.inc | |||
@@ -3,11 +3,11 @@ DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards." | |||
3 | LICENSE = "GPL-2.0-or-later" | 3 | LICENSE = "GPL-2.0-or-later" |
4 | LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" | 4 | LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
5 | 5 | ||
6 | SRC_URI = "git://github.com/nxp-imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" | 6 | SRC_URI = "${UBOOT_SRC};branch=${SRCBRANCH}" |
7 | UBOOT_SRC ?= "git://github.com/nxp-imx/uboot-imx.git;protocol=https" | ||
7 | SRCBRANCH = "lf_v2024.04" | 8 | SRCBRANCH = "lf_v2024.04" |
8 | LOCALVERSION ?= "-imx_v2024.04_6.6.52-2.2.0" | 9 | LOCALVERSION ?= "-${SRCBRANCH}" |
9 | SRCREV = "6c4545203d123c246c5d7995f2893959506d28e0" | 10 | SRCREV = "e3219a5a73445219df605d1492687918d488055c" |
10 | CVE_PRODUCT = "nxp:uboot_secondary_program_loader denx:u-boot" | ||
11 | 11 | ||
12 | DEPENDS += " \ | 12 | DEPENDS += " \ |
13 | bc-native \ | 13 | bc-native \ |
diff --git a/recipes-bsp/u-boot/u-boot-imx_2024.04.bb b/recipes-bsp/u-boot/u-boot-imx_2024.04.bb index 29d83527..69598780 100644 --- a/recipes-bsp/u-boot/u-boot-imx_2024.04.bb +++ b/recipes-bsp/u-boot/u-boot-imx_2024.04.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | # Copyright (C) 2013-2016 Freescale Semiconductor | 1 | # Copyright (C) 2013-2016 Freescale Semiconductor |
2 | # Copyright 2018 (C) O.S. Systems Software LTDA. | 2 | # Copyright 2018 (C) O.S. Systems Software LTDA. |
3 | # Copyright (C) 2017-2024 NXP | 3 | # Copyright 2017-2024 NXP |
4 | 4 | ||
5 | require recipes-bsp/u-boot/u-boot.inc | 5 | require recipes-bsp/u-boot/u-boot.inc |
6 | require u-boot-imx-common_${PV}.inc | 6 | require u-boot-imx-common_${PV}.inc |
@@ -14,6 +14,8 @@ inherit uuu_bootloader_tag | |||
14 | UUU_BOOTLOADER:mx8-generic-bsp = "" | 14 | UUU_BOOTLOADER:mx8-generic-bsp = "" |
15 | UUU_BOOTLOADER:mx9-generic-bsp = "" | 15 | UUU_BOOTLOADER:mx9-generic-bsp = "" |
16 | 16 | ||
17 | TOOLCHAIN_OPTIONS:append = " -Wno-error=implicit-function-declaration" | ||
18 | |||
17 | do_deploy:append:mx8m-generic-bsp() { | 19 | do_deploy:append:mx8m-generic-bsp() { |
18 | # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary | 20 | # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary |
19 | if [ -n "${UBOOT_CONFIG}" ] | 21 | if [ -n "${UBOOT_CONFIG}" ] |