diff options
author | Adrian Dudau <adrian.dudau@enea.com> | 2021-03-24 11:58:07 +0100 |
---|---|---|
committer | Adrian Dudau <adrian.dudau@enea.com> | 2021-03-25 12:27:30 +0100 |
commit | 5f980c14dafb466e1d71e0b6e7487aa522ade9f9 (patch) | |
tree | 0d58f2aea15998482c8baed3510964bfba292cfd /images | |
parent | 23ed226a4b4b7c1cac2c52e6808631d9f0d6f652 (diff) | |
download | meta-el-nfv-access-5f980c14dafb466e1d71e0b6e7487aa522ade9f9.tar.gz |
Upgrade to gatesgarth
This is an initial commit, containing quick fixes and hacks to allow
building the images. All these issues will be re-evaluated and fixed
properly in their own commits.
Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'images')
-rw-r--r-- | images/enea-nfv-access-common.inc | 4 | ||||
-rw-r--r-- | images/enea-nfv-access-host-common.inc | 12 | ||||
-rw-r--r-- | images/enea-nfv-access.bb | 1 |
3 files changed, 10 insertions, 7 deletions
diff --git a/images/enea-nfv-access-common.inc b/images/enea-nfv-access-common.inc index 5472056..a10e2e2 100644 --- a/images/enea-nfv-access-common.inc +++ b/images/enea-nfv-access-common.inc | |||
@@ -18,9 +18,9 @@ rootfs_postinstall_dpkg_cleanup () { | |||
18 | } | 18 | } |
19 | ROOTFS_POSTINSTALL_COMMAND_append += " rootfs_postinstall_dpkg_cleanup;" | 19 | ROOTFS_POSTINSTALL_COMMAND_append += " rootfs_postinstall_dpkg_cleanup;" |
20 | 20 | ||
21 | IMAGE_FSTYPES = "ext4 ext4.gz tar.gz" | 21 | IMAGE_FSTYPES += "ext4 ext4.gz tar.gz" |
22 | 22 | ||
23 | # Add ostree specific image types if sota support is set | 23 | # Add ostree specific image types if sota support is set |
24 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'otaimg wic', ' ', d)}" | 24 | IMAGE_FSTYPES += "${@bb.utils.contains('DISTRO_FEATURES', 'sota', 'ota-ext4 wic', ' ', d)}" |
25 | SOTA_CLIENT = "" | 25 | SOTA_CLIENT = "" |
26 | SOTA_CLIENT_PROV = "" | 26 | SOTA_CLIENT_PROV = "" |
diff --git a/images/enea-nfv-access-host-common.inc b/images/enea-nfv-access-host-common.inc index 1cde827..c0cd896 100644 --- a/images/enea-nfv-access-host-common.inc +++ b/images/enea-nfv-access-host-common.inc | |||
@@ -3,8 +3,6 @@ REQUIRE_FILES = " \ | |||
3 | classes/override_grub-efi.inc \ | 3 | classes/override_grub-efi.inc \ |
4 | " | 4 | " |
5 | REQUIRE_FILES_append_df-efi-secure-boot = " \ | 5 | REQUIRE_FILES_append_df-efi-secure-boot = " \ |
6 | classes/override_image_types_ostree.inc \ | ||
7 | classes/override_image_types_ota.inc \ | ||
8 | classes/override_grub-efi_secureboot.inc \ | 6 | classes/override_grub-efi_secureboot.inc \ |
9 | images/secure-boot.inc \ | 7 | images/secure-boot.inc \ |
10 | " | 8 | " |
@@ -16,6 +14,12 @@ IMAGE_INSTALL += " \ | |||
16 | packagegroup-enea-virtualization-4gusb-modems \ | 14 | packagegroup-enea-virtualization-4gusb-modems \ |
17 | " | 15 | " |
18 | 16 | ||
17 | #This should not be needed, it's a hack. Without it it complains hddimg is not recognize | ||
18 | #See image.bbclass +13. | ||
19 | #inherit image-live | ||
20 | |||
21 | IMAGE_FSTYPES += "hddimg" | ||
22 | |||
19 | # Set labels for GRUB and SYSLINUX | 23 | # Set labels for GRUB and SYSLINUX |
20 | LABELS_LIVE = "installer live-boot" | 24 | LABELS_LIVE = "installer live-boot" |
21 | 25 | ||
@@ -30,13 +34,13 @@ AUTO_SYSLINUXMENU_x86-64 = "0" | |||
30 | 34 | ||
31 | # grub-efi-native is needed in recipe-sysroot-native to generate the initial | 35 | # grub-efi-native is needed in recipe-sysroot-native to generate the initial |
32 | # configuration file for grub | 36 | # configuration file for grub |
33 | DEPENDS_append += " grub-efi-native" | 37 | DEPENDS_append += " grub-efi-native qemuwrapper-cross" |
34 | 38 | ||
35 | # If building with sota enabled, build the otaimg before the hddimg, because | 39 | # If building with sota enabled, build the otaimg before the hddimg, because |
36 | # the hddimg needs it as a base image | 40 | # the hddimg needs it as a base image |
37 | python __anonymous() { | 41 | python __anonymous() { |
38 | if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d): | 42 | if bb.utils.contains('DISTRO_FEATURES', 'sota', True, False, d): |
39 | d.appendVarFlag("do_bootimg", "depends", " %s:do_image_otaimg" % d.getVar("IMAGE_BASENAME", True)) | 43 | d.appendVarFlag("do_bootimg", "depends", " %s:do_image_ota_ext4" % d.getVar("IMAGE_BASENAME", True)) |
40 | } | 44 | } |
41 | 45 | ||
42 | # Append OSTree specific parameters to the kernel command line before creating the live image | 46 | # Append OSTree specific parameters to the kernel command line before creating the live image |
diff --git a/images/enea-nfv-access.bb b/images/enea-nfv-access.bb index 9311992..08239ae 100644 --- a/images/enea-nfv-access.bb +++ b/images/enea-nfv-access.bb | |||
@@ -3,5 +3,4 @@ DESCRIPTION = "Image for the host side of the Enea NFV Access Platform with ODM | |||
3 | require images/enea-nfv-access-host-common.inc | 3 | require images/enea-nfv-access-host-common.inc |
4 | 4 | ||
5 | IMAGE_INSTALL += " \ | 5 | IMAGE_INSTALL += " \ |
6 | element-vcpe \ | ||
7 | " | 6 | " |