diff options
author | Yi Zhao <yi.zhao@eng.windriver.com> | 2023-10-14 23:19:43 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-10-16 18:23:53 +0000 |
commit | 28fcb27fbbab03a412f2126da3bec79acda6d9b0 (patch) | |
tree | 75be907434f91400a176d452198b0aaf23fcef9f | |
parent | 69ba7c9276b3b7fa5af12b3881a3e94964545449 (diff) | |
download | meta-cloud-services-28fcb27fbbab03a412f2126da3bec79acda6d9b0.tar.gz |
kirkstone[][PATCH] nss-pam-ldapd: upgrade 0.9.8 -> 0.9.12
Changelog:
https://arthurdejong.org/nss-pam-ldapd/release-0-9-12
Add a patch to fix shebang to python3 for getent.py and chsh.py.
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch | 34 | ||||
-rw-r--r-- | recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb (renamed from recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb) | 5 |
2 files changed, 37 insertions, 2 deletions
diff --git a/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch b/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch new file mode 100644 index 0000000..86e9f7b --- /dev/null +++ b/recipes-support/nss-pam-ldapd/files/0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From fb9c5b955da462695e0a662aebfa13493eaf3978 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yi Zhao <yi.zhao@windriver.com> | ||
3 | Date: Fri, 13 Oct 2023 22:28:25 +0800 | ||
4 | Subject: [PATCH] utils/Makefile.am: fix shebang for chsh.py and getent.py | ||
5 | |||
6 | Update shebang to python3 for chsh.py and getent.py to fix QA issue: | ||
7 | |||
8 | WARNING: nss-pam-ldapd-0.9.12-r0 do_package_qa: QA Issue: File | ||
9 | /usr/share/nslcd-utils/chsh.py in package nss-pam-ldapd contains | ||
10 | reference to TMPDIR | ||
11 | File /usr/share/nslcd-utils/getent.py in package nss-pam-ldapd contains | ||
12 | reference to TMPDIR [buildpaths] | ||
13 | |||
14 | Upstream-Status: Inappropriate [embedded specific] | ||
15 | |||
16 | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> | ||
17 | --- | ||
18 | utils/Makefile.am | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/utils/Makefile.am b/utils/Makefile.am | ||
22 | index a6bccd3..22a50d8 100644 | ||
23 | --- a/utils/Makefile.am | ||
24 | +++ b/utils/Makefile.am | ||
25 | @@ -39,5 +39,5 @@ install-data-hook: | ||
26 | set -ex; for cmd in getent chsh ; do \ | ||
27 | [ -L $(DESTDIR)$(bindir)/$$cmd.$(MODULE_NAME) ] || $(LN_S) $(utilsdir)/$$cmd.py $(DESTDIR)$(bindir)/$$cmd.$(MODULE_NAME) ; \ | ||
28 | chmod a+rx $(DESTDIR)$(utilsdir)/$$cmd.py ; \ | ||
29 | - sed -i -e '1 s|^#!.*|#! $(PYTHON)|;1 s|^#! \([^/].*\)|#! /usr/bin/env \1|' $(DESTDIR)$(utilsdir)/$$cmd.py ; \ | ||
30 | + sed -i -e '1 s|/usr/bin/env python|/usr/bin/env python3|' $(DESTDIR)$(utilsdir)/$$cmd.py ; \ | ||
31 | done | ||
32 | -- | ||
33 | 2.25.1 | ||
34 | |||
diff --git a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb index d7354c4..7f3b9e3 100644 --- a/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.8.bb +++ b/recipes-support/nss-pam-ldapd/nss-pam-ldapd_0.9.12.bb | |||
@@ -16,6 +16,7 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/files:" | |||
16 | 16 | ||
17 | SRC_URI = "\ | 17 | SRC_URI = "\ |
18 | http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \ | 18 | http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \ |
19 | file://0001-utils-Makefile.am-fix-shebang-for-chsh.py-and-getent.patch \ | ||
19 | file://nslcd.init \ | 20 | file://nslcd.init \ |
20 | file://nslcd.service \ | 21 | file://nslcd.service \ |
21 | " | 22 | " |
@@ -23,8 +24,8 @@ SRC_URI = "\ | |||
23 | inherit autotools features_check | 24 | inherit autotools features_check |
24 | REQUIRED_DISTRO_FEATURES = "pam" | 25 | REQUIRED_DISTRO_FEATURES = "pam" |
25 | 26 | ||
26 | SRC_URI[md5sum] = "8c99fdc54f4bf9aca8c5f53fdb1403ff" | 27 | SRC_URI[md5sum] = "cc30ee0ab91d6c94b7a343ae09b5dc69" |
27 | SRC_URI[sha256sum] = "ef7362e7f2003da8c7beb7bcc03c30494acf712625aaac8badc6e7eb16f3453f" | 28 | SRC_URI[sha256sum] = "c6d661e74693cbf531a790631ca93b73f291fb23cc39465b09deb8da2bfb0e14" |
28 | 29 | ||
29 | DEPENDS += "libpam openldap krb5" | 30 | DEPENDS += "libpam openldap krb5" |
30 | 31 | ||