summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMike Frysinger <vapier@google.com>2019-12-01 21:56:07 -0500
committerMike Frysinger <vapier@google.com>2019-12-02 04:23:31 +0000
commit5b3a57c3ffdabe421817dbb63ee243b2c9cd0797 (patch)
tree1d7f352c10c59bf11bba8dcb61639bca5bc60ac2 /setup.py
parent6f8c85ce2a80ea7662939735b185113aa139c78b (diff)
downloadgit-repo-5b3a57c3ffdabe421817dbb63ee243b2c9cd0797.tar.gz
setup.py: add basic packaging files
This is needed to use tox, and tox lets us test multiple Python versions easily. Change-Id: I813c418a8f7109294a4adb9f6b21be459cbeca70 Reviewed-on: https://gerrit-review.googlesource.com/c/git-repo/+/247173 Reviewed-by: David Pursehouse <dpursehouse@collab.net> Tested-by: Mike Frysinger <vapier@google.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py63
1 files changed, 63 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 00000000..e48aa303
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,63 @@
1#!/usr/bin/python
2# -*- coding:utf-8 -*-
3# Copyright 2019 The Android Open Source Project
4#
5# Licensed under the Apache License, Version 2.0 (the 'License");
6# you may not use this file except in compliance with the License.
7# You may obtain a copy of the License at
8#
9# http://www.apache.org/licenses/LICENSE-2.0
10#
11# Unless required by applicable law or agreed to in writing, software
12# distributed under the License is distributed on an "AS IS" BASIS,
13# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
14# See the License for the specific language governing permissions and
15# limitations under the License.
16
17"""Python packaging for repo."""
18
19from __future__ import print_function
20
21import os
22import setuptools
23
24
25TOPDIR = os.path.dirname(os.path.abspath(__file__))
26
27
28# Rip out the first intro paragraph.
29with open(os.path.join(TOPDIR, 'README.md')) as fp:
30 lines = fp.read().splitlines()[2:]
31 end = lines.index('')
32 long_description = ' '.join(lines[0:end])
33
34
35# https://packaging.python.org/tutorials/packaging-projects/
36setuptools.setup(
37 name='repo',
38 version='1.13.8',
39 maintainer='Various',
40 maintainer_email='repo-discuss@googlegroups.com',
41 description='Repo helps manage many Git repositories',
42 long_description=long_description,
43 long_description_content_type='text/plain',
44 url='https://gerrit.googlesource.com/git-repo/',
45 project_urls={
46 'Bug Tracker': 'https://bugs.chromium.org/p/gerrit/issues/list?q=component:repo',
47 },
48 # https://pypi.org/classifiers/
49 classifiers=[
50 'Development Status :: 6 - Mature',
51 'Environment :: Console',
52 'Intended Audience :: Developers',
53 'License :: OSI Approved :: Apache Software License',
54 'Natural Language :: English',
55 'Operating System :: MacOS :: MacOS X',
56 'Operating System :: Microsoft :: Windows :: Windows 10',
57 'Operating System :: POSIX :: Linux',
58 'Topic :: Software Development :: Version Control :: Git',
59 ],
60 # We support Python 2.7 and Python 3.6+.
61 python_requires='>=2.7, ' + ', '.join('!=3.%i.*' % x for x in range(0, 6)),
62 packages=['subcmds'],
63)