summaryrefslogtreecommitdiffstats
path: root/openembedded/packages/ipkg/ipkg-0.99.144/paths.patch
diff options
context:
space:
mode:
Diffstat (limited to 'openembedded/packages/ipkg/ipkg-0.99.144/paths.patch')
-rw-r--r--openembedded/packages/ipkg/ipkg-0.99.144/paths.patch193
1 files changed, 193 insertions, 0 deletions
diff --git a/openembedded/packages/ipkg/ipkg-0.99.144/paths.patch b/openembedded/packages/ipkg/ipkg-0.99.144/paths.patch
new file mode 100644
index 0000000000..f40131e252
--- /dev/null
+++ b/openembedded/packages/ipkg/ipkg-0.99.144/paths.patch
@@ -0,0 +1,193 @@
1Index: C/ipkg.h
2===================================================================
3--- /dev/null 1970-01-01 00:00:00.000000000 +0000
4+++ C/ipkg.h 2005-02-25 15:28:24.000000000 -0600
5@@ -0,0 +1,59 @@
6+/* ipkg.h - the itsy package management system
7+
8+ Carl D. Worth
9+
10+ Copyright (C) 2001 University of Southern California
11+
12+ This program is free software; you can redistribute it and/or
13+ modify it under the terms of the GNU General Public License as
14+ published by the Free Software Foundation; either version 2, or (at
15+ your option) any later version.
16+
17+ This program is distributed in the hope that it will be useful, but
18+ WITHOUT ANY WARRANTY; without even the implied warranty of
19+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
20+ General Public License for more details.
21+*/
22+
23+#ifndef IPKG_H
24+#define IPKG_H
25+
26+#ifdef HAVE_CONFIG_H
27+#include "config.h"
28+#endif
29+
30+#if 0
31+#define IPKG_DEBUG_NO_TMP_CLEANUP
32+#endif
33+
34+#include "includes.h"
35+#include "ipkg_conf.h"
36+#include "ipkg_message.h"
37+
38+#define IPKG_PKG_EXTENSION ".ipk"
39+#define DPKG_PKG_EXTENSION ".deb"
40+
41+#define IPKG_LEGAL_PKG_NAME_CHARS "abcdefghijklmnopqrstuvwxyz0123456789.+-"
42+#define IPKG_PKG_VERSION_SEP_CHAR '_'
43+
44+#define IPKG_STATE_DIR_PREFIX IPKGDIR
45+#define IPKG_LISTS_DIR_SUFFIX "lists"
46+#define IPKG_INFO_DIR_SUFFIX "info"
47+#define IPKG_STATUS_FILE_SUFFIX "status"
48+
49+#define IPKG_BACKUP_SUFFIX "-ipkg.backup"
50+
51+#define IPKG_LIST_DESCRIPTION_LENGTH 128
52+
53+enum ipkg_error {
54+ IPKG_SUCCESS = 0,
55+ IPKG_PKG_DEPS_UNSATISFIED,
56+ IPKG_PKG_IS_ESSENTIAL,
57+ IPKG_PKG_HAS_DEPENDENTS,
58+ IPKG_PKG_HAS_NO_CANDIDATE
59+};
60+typedef enum ipkg_error ipkg_error_t;
61+
62+extern int ipkg_state_changed;
63+
64+#endif
65Index: C/configure.ac
66===================================================================
67--- C.orig/configure.ac 2005-02-25 15:27:58.000000000 -0600
68+++ C/configure.ac 2005-02-25 15:28:00.000000000 -0600
69@@ -10,6 +10,14 @@
70 test -f $top_builddir/configure && break
71 done
72
73+AC_MSG_CHECKING([ipkg data location])
74+AC_ARG_WITH(ipkgdir,
75+ AS_HELP_STRING([--with-ipkgdir=ARG],
76+ [Where to look for plugins (default=${libdir}/ipkg)]),
77+ [ipkgdir=$withval],
78+ [ipkgdir='${libdir}/ipkg'])
79+AC_MSG_RESULT($ipkgdir)
80+AC_SUBST(ipkgdir)
81
82 # Checks for programs
83 AC_PROG_AWK
84@@ -50,4 +58,4 @@
85 AC_FUNC_VPRINTF
86 AC_CHECK_FUNCS([memmove memset mkdir regcomp strchr strcspn strdup strerror strndup strrchr strstr strtol strtoul sysinfo utime])
87
88-AC_OUTPUT(Makefile etc/Makefile replace/Makefile familiar/Makefile familiar/control familiar/control-unstripped familiar/libipkg-control familiar/libipkg-dev-control libbb/Makefile libipkg.pc ipkg.h)
89+AC_OUTPUT(Makefile etc/Makefile replace/Makefile familiar/Makefile familiar/control familiar/control-unstripped familiar/libipkg-control familiar/libipkg-dev-control libbb/Makefile libipkg.pc)
90Index: C/Makefile.am
91===================================================================
92--- C.orig/Makefile.am 2005-02-25 15:27:58.000000000 -0600
93+++ C/Makefile.am 2005-02-25 15:28:00.000000000 -0600
94@@ -3,7 +3,8 @@
95
96 HOST_CPU=@host_cpu@
97 BUILD_CPU=@build_cpu@
98-ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\"
99+ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"@host_cpu@\" -DBUILD_CPU=@build_cpu@ \
100+ -DLIBDIR=\"$(libdir)\" -DIPKGDIR=\"$(ipkgdir)\" -DSYSCONFDIR=\"$(sysconfdir)\"
101
102 bin_PROGRAMS = ipkg-cl
103
104Index: C/ipkg_conf.c
105===================================================================
106--- C.orig/ipkg_conf.c 2005-03-12 21:08:36.000000000 +1030
107+++ C/ipkg_conf.c 2005-03-12 21:09:46.000000000 +1030
108@@ -103,7+103,7 @@
109 nv_pair_list_t tmp_dest_nv_pair_list;
110 char * lists_dir =NULL;
111 glob_t globbuf;
112- char *etc_ipkg_conf_pattern = "/etc/ipkg/*.conf";
113+ char *etc_ipkg_conf_pattern = SYSCONFDIR"/ipkg/*.conf";
114 char *pending_dir =NULL;
115
116 memset(conf, 0, sizeof(ipkg_conf_t));
117Index: C/args.h
118===================================================================
119--- C.orig/args.h 2005-03-12 21:49:31.000000000 +1030
120+++ C/args.h 2005-03-12 21:49:42.000000000 +1030
121@@ -43,7 +43,7 @@
122 };
123 typedef struct args args_t;
124
125-#define ARGS_DEFAULT_CONF_FILE_DIR "/etc"
126+#define ARGS_DEFAULT_CONF_FILE_DIR SYSCONFDIR
127 #define ARGS_DEFAULT_CONF_FILE_NAME "ipkg.conf"
128 #define ARGS_DEFAULT_DEST NULL
129 #define ARGS_DEFAULT_FORCE_DEFAULTS 0
130Index: C/ipkg.h.in
131===================================================================
132--- C.orig/ipkg.h.in 2005-02-25 15:27:58.000000000 -0600
133+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
134@@ -1,60 +0,1 @@
135-/* ipkg.h - the itsy package management system
136-
137- Carl D. Worth
138-
139- Copyright (C) 2001 University of Southern California
140-
141- This program is free software; you can redistribute it and/or
142- modify it under the terms of the GNU General Public License as
143- published by the Free Software Foundation; either version 2, or (at
144- your option) any later version.
145-
146- This program is distributed in the hope that it will be useful, but
147- WITHOUT ANY WARRANTY; without even the implied warranty of
148- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
149- General Public License for more details.
150-*/
151-
152-#ifndef IPKG_H
153-#define IPKG_H
154-
155-#ifdef HAVE_CONFIG_H
156-#include "config.h"
157-#endif
158-
159-#if 0
160-#define IPKG_DEBUG_NO_TMP_CLEANUP
161-#endif
162-
163-#include "includes.h"
164-#include "ipkg_conf.h"
165-#include "ipkg_message.h"
166-
167-#define IPKG_PKG_EXTENSION ".ipk"
168-#define DPKG_PKG_EXTENSION ".deb"
169-
170-#define IPKG_LEGAL_PKG_NAME_CHARS "abcdefghijklmnopqrstuvwxyz0123456789.+-"
171-#define IPKG_PKG_VERSION_SEP_CHAR '_'
172-
173-#define IPKG_STATE_DIR_PREFIX LIBDIR"/ipkg"
174-#define IPKG_LISTS_DIR_SUFFIX "lists"
175-#define IPKG_INFO_DIR_SUFFIX "info"
176-#define IPKG_STATUS_FILE_SUFFIX "status"
177-
178-#define IPKG_BACKUP_SUFFIX "-ipkg.backup"
179-
180-#define IPKG_LIST_DESCRIPTION_LENGTH 128
181-
182-enum ipkg_error {
183- IPKG_SUCCESS = 0,
184- IPKG_PKG_DEPS_UNSATISFIED,
185- IPKG_PKG_IS_ESSENTIAL,
186- IPKG_PKG_HAS_DEPENDENTS,
187- IPKG_PKG_HAS_NO_CANDIDATE
188-};
189-typedef enum ipkg_error ipkg_error_t;
190-
191-extern int ipkg_state_changed;
192-
193-#endif