summaryrefslogtreecommitdiffstats
path: root/meta/recipes-tbd/meta/meta-toolchain.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-tbd/meta/meta-toolchain.bb')
-rw-r--r--meta/recipes-tbd/meta/meta-toolchain.bb11
1 files changed, 2 insertions, 9 deletions
diff --git a/meta/recipes-tbd/meta/meta-toolchain.bb b/meta/recipes-tbd/meta/meta-toolchain.bb
index 633f5f1990..2fab8f94b2 100644
--- a/meta/recipes-tbd/meta/meta-toolchain.bb
+++ b/meta/recipes-tbd/meta/meta-toolchain.bb
@@ -72,15 +72,8 @@ do_populate_sdk() {
72 #rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}/lib/*.la 72 #rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}/lib/*.la
73 rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/*.la 73 rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/*.la
74 74
75 # Create an appropriate setup so the dynamic loader can find libs in 75 # Link the ld.so.cache file into the hosts filesystem
76 # both the host system and the toolchain directories 76 ln -s /etc/ld.so.cache ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.cache
77 echo ${SDKPATHNATIVE}${libdir} > ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
78 echo ${SDKPATHNATIVE}${base_libdir} >> ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
79 echo "include /etc/ld.so.conf" >> ${SDK_OUTPUT}/${SDKPATHNATIVE}/etc/ld.so.conf
80 echo "#!/bin/sh" > ${SDK_OUTPUT}/${SDKPATH}/postinstall
81 echo "ldconfig -f ${SDKPATHNATIVE}/etc/ld.so.conf -C /${SDKPATHNATIVE}/etc/ld.so.cache" >> ${SDK_OUTPUT}/${SDKPATH}/postinstall
82 chmod a+x ${SDK_OUTPUT}/${SDKPATH}/postinstall
83
84 77
85 # Setup site file for external use 78 # Setup site file for external use
86 siteconfig=${SDK_OUTPUT}/${SDKPATH}/site-config-${MULTIMACH_TARGET_SYS} 79 siteconfig=${SDK_OUTPUT}/${SDKPATH}/site-config-${MULTIMACH_TARGET_SYS}