summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/xxhash/xxhash_0.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/xxhash/xxhash_0.8.2.bb')
-rw-r--r--meta/recipes-support/xxhash/xxhash_0.8.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/xxhash/xxhash_0.8.2.bb b/meta/recipes-support/xxhash/xxhash_0.8.2.bb
new file mode 100644
index 0000000000..f16b183c95
--- /dev/null
+++ b/meta/recipes-support/xxhash/xxhash_0.8.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Extremely fast non-cryptographic hash algorithm"
2DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \
3working at speeds close to RAM limits."
4HOMEPAGE = "http://www.xxhash.com/"
5LICENSE = "BSD-2-Clause & GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=13be6b481ff5616f77dda971191bb29b \
7 file://cli/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 "
9
10SRC_URI = "git://github.com/Cyan4973/xxHash.git;branch=release;protocol=https"
11UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
12
13SRCREV = "bbb27a5efb85b92a0486cf361a8635715a53f6ba"
14
15S = "${WORKDIR}/git"
16
17CFLAGS += "${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Og', '-DXXH_NO_INLINE_HINTS', '', d)}"
18
19do_compile () {
20 oe_runmake all
21}
22
23do_install () {
24 oe_runmake DESTDIR=${D} install
25}
26
27BBCLASSEXTEND = "native nativesdk"