summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vte/vte_0.52.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/vte/vte_0.52.0.bb')
-rw-r--r--meta/recipes-support/vte/vte_0.52.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/vte/vte_0.52.0.bb b/meta/recipes-support/vte/vte_0.52.0.bb
new file mode 100644
index 0000000000..254d64effa
--- /dev/null
+++ b/meta/recipes-support/vte/vte_0.52.0.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Virtual terminal emulator GTK+ widget library"
2BUGTRACKER = "https://bugzilla.gnome.org/buglist.cgi?product=vte"
3LICENSE = "LGPLv2.1+"
4DEPENDS = "glib-2.0 gtk+3 libpcre2 intltool-native libxml2-native gperf-native"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8inherit gnomebase gtk-doc distro_features_check upstream-version-is-even gobject-introspection
9
10# vapigen.m4 is required when vala is not present (but the one from vala should be used normally)
11SRC_URI += "file://0001-Don-t-enable-stack-protection-by-default.patch \
12 ${@bb.utils.contains('PACKAGECONFIG', 'vala', '', 'file://0001-Add-m4-vapigen.m4.patch', d) } \
13 "
14SRC_URI[archive.md5sum] = "95b0d12864f7374128da33998e756e75"
15SRC_URI[archive.sha256sum] = "d5ae72dddd57af493afa10ca2a290f284e588021b0bd8aaaa63dbb75de7c0567"
16
17ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
18
19# Instead of "inherit vala" we do the relevant settings here so we can
20# set DEPENDS based on PACKAGECONFIG.
21
22# Our patched version of Vala looks in STAGING_DATADIR for .vapi files
23export STAGING_DATADIR
24# Upstream Vala >= 0.11 looks in XDG_DATA_DIRS for .vapi files
25export XDG_DATA_DIRS = "${STAGING_DATADIR}"
26
27# Help g-ir-scanner find the .so for linking
28do_compile_prepend() {
29 export GIR_EXTRA_LIBS_PATH="${B}/src/.libs"
30}
31
32# Package additional files
33FILES_${PN}-dev += "${datadir}/vala/vapi/*"
34
35PACKAGECONFIG ??= "gnutls"
36PACKAGECONFIG[vala] = "--enable-vala,--disable-vala,vala-native vala"
37PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
38
39CFLAGS += "-D_GNU_SOURCE"
40
41# libtool adds "-nostdlib" when g++ is used. This breaks PIE builds.
42# Use libtool-cross (which has a hack to prevent that) instead.
43EXTRA_OEMAKE_class-target = "LIBTOOL=${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool"
44
45PACKAGES =+ "libvte"
46FILES_libvte = "${libdir}/*.so.* ${libdir}/girepository-1.0/*"