summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/vim/vim_9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/vim/vim_9.1.bb')
-rw-r--r--meta/recipes-support/vim/vim_9.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-support/vim/vim_9.1.bb b/meta/recipes-support/vim/vim_9.1.bb
new file mode 100644
index 0000000000..fee9f055e9
--- /dev/null
+++ b/meta/recipes-support/vim/vim_9.1.bb
@@ -0,0 +1,23 @@
1require vim.inc
2
3PROVIDES = "xxd"
4
5RDEPENDS:${PN} = "ncurses-terminfo-base ${PN}-xxd"
6# Recommend that runtime data is installed along with vim
7RRECOMMENDS:${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
8
9PACKAGECONFIG:class-native = ""
10BBCLASSEXTEND = "native nativesdk"
11
12PACKAGES =+ "${PN}-xxd"
13FILES:${PN}-xxd = "${bindir}/xxd"
14RPROVIDES:${PN}-xxd = "xxd"
15
16ALTERNATIVE:${PN}-xxd = "xxd"
17ALTERNATIVE_TARGET[xxd] = "${bindir}/xxd"
18ALTERNATIVE_LINK_NAME[xxd] = "${bindir}/xxd"
19
20# We override the default in security_flags.inc because vim (not vim-tiny!) will abort
21# in many places for _FORTIFY_SOURCE=2. Security flags become part of CC.
22#
23lcl_maybe_fortify = "${@oe.utils.conditional('DEBUG_BUILD','1','','-D_FORTIFY_SOURCE=1',d)}"