summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/taglib/taglib_1.13.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/taglib/taglib_1.13.1.bb')
-rw-r--r--meta/recipes-support/taglib/taglib_1.13.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-support/taglib/taglib_1.13.1.bb b/meta/recipes-support/taglib/taglib_1.13.1.bb
new file mode 100644
index 0000000000..3f0a759f95
--- /dev/null
+++ b/meta/recipes-support/taglib/taglib_1.13.1.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Library for reading and editing the meta-data of popular audio formats"
2DESCRIPTION = "Platform-independent library (tested on Windows/Linux) for reading and writing metadata in media files, including video, audio, and photo formats. This is a convenient one-stop-shop to present or tag all your media collection, regardless of which format/container these might use. You can read/write the standard or more common tags/properties of a media, or you can also create and retrieve your own custom tags."
3SECTION = "libs/multimedia"
4HOMEPAGE = "http://taglib.github.io/"
5LICENSE = "LGPL-2.1-only | MPL-1.1"
6LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
7 file://COPYING.MPL;md5=bfe1f75d606912a4111c90743d6c7325 \
8 file://taglib/audioproperties.h;beginline=1;endline=24;md5=9df2c7399519b7310568a7c55042ecee"
9
10DEPENDS = "zlib"
11
12SRC_URI = "http://taglib.github.io/releases/${BP}.tar.gz"
13
14SRC_URI[sha256sum] = "c8da2b10f1bfec2cd7dbfcd33f4a2338db0765d851a50583d410bacf055cfd0b"
15
16UPSTREAM_CHECK_URI = "https://taglib.org/"
17
18BINCONFIG = "${bindir}/taglib-config"
19
20inherit cmake pkgconfig binconfig-disabled
21
22PACKAGES =+ "${PN}-c"
23FILES:${PN}-c = "${libdir}/libtag_c.so.*"
24
25EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
26 -DCMAKE_DISABLE_FIND_PACKAGE_Boost=TRUE \
27 -DHAVE_BOOST_BYTESWAP=FALSE \
28 -DCMAKE_CXX_STANDARD=11 \
29 -DCMAKE_CXX_STANDARD_REQUIRED=OFF \
30 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
31"
32CXXFLAGS += "-std=c++11"
33
34do_configure:prepend () {
35 rm -f ${S}/admin/ltmain.sh
36 rm -f ${S}/admin/libtool.m4.in
37}
38
39# without -fPIC depending packages failed with many error like:
40# | <...>/ld: error: <...>/usr/lib/libtag.a(modfilebase.cpp.o): requires unsupported dynamic reloc R_ARM_THM_MOVW_ABS_NC; recompile with -fPIC
41CXXFLAGS += "-fPIC"