summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/serf/serf_1.3.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/serf/serf_1.3.10.bb')
-rw-r--r--meta/recipes-support/serf/serf_1.3.10.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-support/serf/serf_1.3.10.bb b/meta/recipes-support/serf/serf_1.3.10.bb
new file mode 100644
index 0000000000..c6b51452aa
--- /dev/null
+++ b/meta/recipes-support/serf/serf_1.3.10.bb
@@ -0,0 +1,40 @@
1SUMMARY = "High-Performance Asynchronous HTTP Client Library"
2DESCRIPTION = "The Apache Serf library is a C-based HTTP client library built upon the Apache \
3Portable Runtime (APR) library. It multiplexes connections, running the \
4read/write communication asynchronously. Memory copies and transformations are \
5kept to a minimum to provide high performance operation."
6HOMEPAGE = "http://serf.apache.org/"
7SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
8 file://norpath.patch \
9 file://env.patch \
10 file://0002-SConstruct-Fix-path-quoting-for-.def-generator.patch \
11 file://0003-gen_def.patch \
12 file://SConstruct.stop.creating.directories.without.sandbox-install.prefix.patch \
13 "
14
15SRC_URI[sha256sum] = "be81ef08baa2516ecda76a77adf7def7bc3227eeb578b9a33b45f7b41dc064e6"
16
17LICENSE = "Apache-2.0"
18LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
19
20inherit scons
21
22DEPENDS += " openssl apr apr-util util-linux expat"
23
24EXTRA_OESCONS = " \
25 LIBDIR=${libdir} \
26 --install-sandbox=${D} \
27 CC="${CC}" \
28 CFLAGS="${CFLAGS}" \
29 LINKFLAGS="${LDFLAGS}" \
30 APR=`which apr-1-config` \
31 APU=`which apu-1-config` \
32 OPENSSL="${STAGING_EXECPREFIXDIR}" \
33 "
34
35# scons creates non-reproducible archives
36do_install:append() {
37 rm ${D}/${libdir}/*.a
38}
39
40BBCLASSEXTEND = "native nativesdk"