summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/rng-tools/rng-tools_6.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/rng-tools/rng-tools_6.16.bb')
-rw-r--r--meta/recipes-support/rng-tools/rng-tools_6.16.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-support/rng-tools/rng-tools_6.16.bb b/meta/recipes-support/rng-tools/rng-tools_6.16.bb
index f0aa3ff93f..ed755ae705 100644
--- a/meta/recipes-support/rng-tools/rng-tools_6.16.bb
+++ b/meta/recipes-support/rng-tools/rng-tools_6.16.bb
@@ -50,9 +50,9 @@ do_configure:prepend() {
50} 50}
51 51
52do_install:append() { 52do_install:append() {
53 install -Dm 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/rng-tools 53 install -Dm 0644 ${UNPACKDIR}/default ${D}${sysconfdir}/default/rng-tools
54 install -Dm 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/rng-tools 54 install -Dm 0755 ${UNPACKDIR}/init ${D}${sysconfdir}/init.d/rng-tools
55 install -Dm 0644 ${WORKDIR}/rng-tools.service \ 55 install -Dm 0644 ${UNPACKDIR}/rng-tools.service \
56 ${D}${systemd_system_unitdir}/rng-tools.service 56 ${D}${systemd_system_unitdir}/rng-tools.service
57 sed -i \ 57 sed -i \
58 -e 's,@SYSCONFDIR@,${sysconfdir},g' \ 58 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
@@ -67,3 +67,7 @@ do_install:append() {
67 ${D}${systemd_system_unitdir}/rng-tools.service 67 ${D}${systemd_system_unitdir}/rng-tools.service
68 fi 68 fi
69} 69}
70
71# libargp detection fails
72# http://errors.yoctoproject.org/Errors/Details/766951/
73CFLAGS += "-Wno-error=incompatible-pointer-types"