diff options
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.4.5.1.bb')
-rw-r--r-- | meta/recipes-support/ptest-runner/ptest-runner_2.4.5.1.bb | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.5.1.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.5.1.bb new file mode 100644 index 0000000000..9f6bb399b4 --- /dev/null +++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.5.1.bb | |||
@@ -0,0 +1,38 @@ | |||
1 | SUMMARY = "A C program to run all installed ptests" | ||
2 | DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \ | ||
3 | program which loops through all installed ptest test suites and \ | ||
4 | runs them in sequence." | ||
5 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/" | ||
6 | |||
7 | LICENSE = "GPL-2.0-or-later" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" | ||
9 | |||
10 | SRCREV = "c99e8c2737ff802f110612cc2d90c60233c33255" | ||
11 | |||
12 | SRC_URI = "git://git.yoctoproject.org/ptest-runner2;branch=master;protocol=https \ | ||
13 | " | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | FILES:${PN} = "${bindir}/ptest-runner ${bindir}/ptest-runner-collect-system-data" | ||
18 | |||
19 | EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\""" | ||
20 | |||
21 | do_compile () { | ||
22 | oe_runmake | ||
23 | } | ||
24 | |||
25 | do_install () { | ||
26 | install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner | ||
27 | install -D -m 0755 ${S}/ptest-runner-collect-system-data ${D}${bindir}/ptest-runner-collect-system-data | ||
28 | } | ||
29 | |||
30 | RDEPENDS:${PN}:append:libc-glibc = " libgcc" | ||
31 | |||
32 | # pstree is called by ptest-runner-collect-system-data | ||
33 | RDEPENDS:${PN}:append = " pstree" | ||
34 | |||
35 | # Create a non-root user that test suites can use easily | ||
36 | inherit useradd | ||
37 | USERADD_PACKAGES = "${PN}" | ||
38 | USERADD_PARAM:${PN} = "--system --no-create-home --home / --user-group ptest" | ||