summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
new file mode 100644
index 0000000000..ba0eb03799
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "cce0edb4282ee081d043030bfdf29f3e4052f86c"
11PV .= "+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
14"
15UPSTREAM_VERSION_UNKNOWN = "1"
16
17S = "${WORKDIR}/git"
18
19FILES_${PN} = "${bindir}/ptest-runner"
20
21EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
22
23do_compile () {
24 oe_runmake
25}
26
27do_install () {
28 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
29}