summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.2.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.2.bb
new file mode 100644
index 0000000000..622d23ba91
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.2.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "49956f65bb53ea2a2c1b394e5e59ffdfcdcc490f"
11PV = "2.2+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
14S = "${WORKDIR}/git"
15
16FILES_${PN} = "${bindir}/ptest-runner"
17
18EXTRA_OEMAKE = "-e MAKEFLAGS="
19
20do_compile () {
21 oe_runmake
22}
23
24do_install () {
25 install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
26}