summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/pinentry/pinentry_1.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/pinentry/pinentry_1.2.1.bb')
-rw-r--r--meta/recipes-support/pinentry/pinentry_1.2.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/pinentry/pinentry_1.2.1.bb b/meta/recipes-support/pinentry/pinentry_1.2.1.bb
new file mode 100644
index 0000000000..7daf80f36e
--- /dev/null
+++ b/meta/recipes-support/pinentry/pinentry_1.2.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
8LICENSE = "GPL-2.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
11DEPENDS = "gettext-native libassuan libgpg-error"
12
13UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
14SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://libassuan_pkgconf.patch \
16 file://gpg-error_pkconf.patch \
17"
18
19SRC_URI[sha256sum] = "457a185e5a85238fb945a955dc6352ab962dc8b48720b62fc9fa48c7540a4067"
20
21inherit autotools pkgconfig
22
23PACKAGECONFIG ??= "ncurses"
24
25PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
26PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qtbase-native qtbase"
27PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
28
29PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"
30
31EXTRA_OECONF = " \
32 --disable-rpath \
33"
34EXTRA_OECONF:append:libc-musl = " \
35 ac_cv_should_define__xopen_source=yes \
36"
37
38BBCLASSEXTEND = "native nativesdk"