summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/pinentry/pinentry_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/pinentry/pinentry_1.1.1.bb')
-rw-r--r--meta/recipes-support/pinentry/pinentry_1.1.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-support/pinentry/pinentry_1.1.1.bb b/meta/recipes-support/pinentry/pinentry_1.1.1.bb
new file mode 100644
index 0000000000..98577fe3ef
--- /dev/null
+++ b/meta/recipes-support/pinentry/pinentry_1.1.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
11DEPENDS = "gettext-native libassuan libgpg-error"
12
13UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
14SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
15 file://libassuan_pkgconf.patch \
16 file://gpg-error_pkconf.patch \
17"
18
19SRC_URI[sha256sum] = "cd12a064013ed18e2ee8475e669b9f58db1b225a0144debdb85a68cecddba57f"
20
21inherit autotools pkgconfig
22
23PACKAGECONFIG ??= "ncurses libcap"
24
25PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
26PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
27PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qtbase-native qtbase"
28PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
29
30PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"
31
32EXTRA_OECONF = " \
33 --disable-rpath \
34"
35
36BBCLASSEXTEND = "native nativesdk"