summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/p11-kit/p11-kit_0.25.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/p11-kit/p11-kit_0.25.2.bb')
-rw-r--r--meta/recipes-support/p11-kit/p11-kit_0.25.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/p11-kit/p11-kit_0.25.2.bb b/meta/recipes-support/p11-kit/p11-kit_0.25.2.bb
new file mode 100644
index 0000000000..d00ef2daf5
--- /dev/null
+++ b/meta/recipes-support/p11-kit/p11-kit_0.25.2.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2DESCRIPTION = " Provides a standard configuration setup for installing PKCS#11 modules in such a way that they're discoverable. Also solves problems with coordinating the use of PKCS#11 by different components or libraries living in the same process."
3HOMEPAGE = "https://p11-glue.github.io/p11-glue/p11-kit.html"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
6
7inherit meson gettext pkgconfig gtk-doc bash-completion manpages
8
9DEPENDS = "libtasn1 libtasn1-native libffi"
10
11DEPENDS:append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
12
13SRC_URI = "gitsm://github.com/p11-glue/p11-kit;branch=master;protocol=https"
14SRCREV = "66d6b42ef8dd84fcd8e199ac9f23f822f1a058c9"
15S = "${WORKDIR}/git"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native"
19PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates"
20
21GTKDOC_MESON_OPTION = 'gtk_doc'
22
23FILES:${PN} += " \
24 ${libdir}/p11-kit-proxy.so \
25 ${libdir}/pkcs11/*.so \
26 ${libdir}/pkcs11/*.la \
27 ${systemd_user_unitdir}/*"
28
29# PN contains p11-kit-proxy.so, a symlink to a loadable module
30INSANE_SKIP:${PN} = "dev-so"
31
32BBCLASSEXTEND = "native nativesdk"