summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/numactl/numactl_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/numactl/numactl_git.bb')
-rw-r--r--meta/recipes-support/numactl/numactl_git.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-support/numactl/numactl_git.bb b/meta/recipes-support/numactl/numactl_git.bb
index 6c8a667a41..bd16df91ec 100644
--- a/meta/recipes-support/numactl/numactl_git.bb
+++ b/meta/recipes-support/numactl/numactl_git.bb
@@ -3,17 +3,17 @@ HOMEPAGE = "http://oss.sgi.com/projects/libnuma/"
3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \ 3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
4to run other programs with a specific NUMA policy and a libnuma to do \ 4to run other programs with a specific NUMA policy and a libnuma to do \
5allocations with NUMA policy in applications." 5allocations with NUMA policy in applications."
6LICENSE = "GPL-2.0 & LGPL-2.1" 6LICENSE = "GPL-2.0-only & LGPL-2.1-only"
7SECTION = "apps" 7SECTION = "apps"
8 8
9inherit autotools-brokensep ptest 9inherit autotools-brokensep ptest
10 10
11LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb" 11LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=9f34c3af4ed6f3f5df0da5f3c0835a43"
12 12
13SRCREV = "dd6de072c92c892a86e18c0fd0dfa1ba57a9a05d" 13SRCREV = "3871b1c42fc71bceadafd745d2eff5dddfc2d67e"
14PV = "2.0.14" 14PV = "2.0.18"
15 15
16SRC_URI = "git://github.com/numactl/numactl \ 16SRC_URI = "git://github.com/numactl/numactl;branch=master;protocol=https \
17 file://Fix-the-test-output-format.patch \ 17 file://Fix-the-test-output-format.patch \
18 file://Makefile \ 18 file://Makefile \
19 file://run-ptest \ 19 file://run-ptest \
@@ -22,8 +22,8 @@ SRC_URI = "git://github.com/numactl/numactl \
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25LDFLAGS_append_riscv64 = " -latomic" 25LDFLAGS:append:riscv64 = " -latomic"
26LDFLAGS_append_riscv32 = " -latomic" 26LDFLAGS:append:riscv32 = " -latomic"
27 27
28do_install() { 28do_install() {
29 oe_runmake DESTDIR=${D} prefix=${D}/usr install 29 oe_runmake DESTDIR=${D} prefix=${D}/usr install
@@ -56,4 +56,4 @@ do_install_ptest() {
56 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/ 56 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
57} 57}
58 58
59RDEPENDS_${PN}-ptest = "bash" 59RDEPENDS:${PN}-ptest = "bash"