summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/npth/npth_1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/npth/npth_1.7.bb')
-rw-r--r--meta/recipes-support/npth/npth_1.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-support/npth/npth_1.7.bb b/meta/recipes-support/npth/npth_1.7.bb
new file mode 100644
index 0000000000..0cf35565a3
--- /dev/null
+++ b/meta/recipes-support/npth/npth_1.7.bb
@@ -0,0 +1,21 @@
1SUMMARY = "New GNU Portable Threads library"
2DESCRIPTION = "nPth is a library to provide the GNU Pth API and thus a non-preemptive threads implementation. "
3HOMEPAGE = "https://gnupg.org/software/npth/"
4SECTION = "libs"
5LICENSE = "LGPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2caced0b25dfefd4c601d92bd15116de"
7UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
8
9SRC_URI = "${GNUPG_MIRROR}/npth/npth-${PV}.tar.bz2 \
10 file://musl-fix.patch \
11 "
12
13SRC_URI[sha256sum] = "8589f56937b75ce33b28d312fccbf302b3b71ec3f3945fde6aaa74027914ad05"
14
15inherit autotools multilib_header
16
17do_install:append() {
18 oe_multilib_header npth.h
19}
20
21BBCLASSEXTEND = "native nativesdk"