summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nghttp2/nghttp2_1.61.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/nghttp2/nghttp2_1.61.0.bb')
-rw-r--r--meta/recipes-support/nghttp2/nghttp2_1.61.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/nghttp2/nghttp2_1.61.0.bb b/meta/recipes-support/nghttp2/nghttp2_1.61.0.bb
new file mode 100644
index 0000000000..ad85576dcb
--- /dev/null
+++ b/meta/recipes-support/nghttp2/nghttp2_1.61.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
7SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz"
8SRC_URI[sha256sum] = "c0e660175b9dc429f11d25b9507a834fb752eea9135ab420bb7cb7e9dbcc9654"
9
10inherit cmake manpages python3native github-releases
11PACKAGECONFIG[manpages] = ""
12
13# examples are never installed, and don't need to be built in the
14# first place
15EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF -DENABLE_PYTHON_BINDINGS=OFF"
16
17PACKAGES =+ "lib${BPN} ${PN}-proxy "
18
19RDEPENDS:${PN} = "${PN}-proxy (>= ${PV})"
20RDEPENDS:${PN}:class-native = ""
21RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
22
23ALLOW_EMPTY:${PN} = "1"
24FILES:${PN} = ""
25FILES:lib${BPN} = "${libdir}/*${SOLIBS}"
26FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
27
28BBCLASSEXTEND = "native nativesdk"