summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nettle/nettle_3.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/nettle/nettle_3.7.1.bb')
-rw-r--r--meta/recipes-support/nettle/nettle_3.7.1.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/recipes-support/nettle/nettle_3.7.1.bb b/meta/recipes-support/nettle/nettle_3.7.1.bb
deleted file mode 100644
index d6bb1c84c6..0000000000
--- a/meta/recipes-support/nettle/nettle_3.7.1.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1SUMMARY = "A low level cryptographic library"
2HOMEPAGE = "http://www.lysator.liu.se/~nisse/nettle/"
3DESCRIPTION = "It tries to solve a problem of providing a common set of \
4cryptographic algorithms for higher-level applications by implementing a \
5context-independent set of cryptographic algorithms"
6SECTION = "libs"
7LICENSE = "LGPLv3+ | GPLv2+"
8
9LIC_FILES_CHKSUM = "file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \
10 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://serpent-decrypt.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e \
12 file://serpent-set-key.c;beginline=14;endline=36;md5=ca0d220bc413e1842ecc507690ce416e"
13
14DEPENDS += "gmp"
15
16SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
17 file://Add-target-to-only-build-tests-not-run-them.patch \
18 file://run-ptest \
19 file://check-header-files-of-openssl-only-if-enable_.patch \
20 "
21
22SRC_URI_append_class-target = "\
23 file://dlopen-test.patch \
24 "
25
26SRC_URI[sha256sum] = "156621427c7b00a75ff9b34b770b95d34f80ef7a55c3407de94b16cbf436c42e"
27
28UPSTREAM_CHECK_REGEX = "nettle-(?P<pver>\d+(\.\d+)+)\.tar"
29
30inherit autotools ptest multilib_header
31
32EXTRA_AUTORECONF += "--exclude=aclocal"
33
34EXTRA_OECONF = "--disable-openssl"
35
36do_compile_ptest() {
37 oe_runmake buildtest
38}
39
40do_install_append() {
41 oe_multilib_header nettle/version.h
42}
43
44do_install_ptest() {
45 install -d ${D}${PTEST_PATH}/testsuite/
46 install ${S}/testsuite/gold-bug.txt ${D}${PTEST_PATH}/testsuite/
47 install ${S}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
48 # tools can be found in PATH, not in ../tools/
49 sed -i -e 's|../tools/||' ${D}${PTEST_PATH}/testsuite/*-test
50 install ${B}/testsuite/*-test ${D}${PTEST_PATH}/testsuite/
51}
52
53RDEPENDS_${PN}-ptest += "${PN}-dev"
54INSANE_SKIP_${PN}-ptest += "dev-deps"
55
56BBCLASSEXTEND = "native nativesdk"