summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lz4/lz4_1.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/lz4/lz4_1.9.4.bb')
-rw-r--r--meta/recipes-support/lz4/lz4_1.9.4.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.9.4.bb b/meta/recipes-support/lz4/lz4_1.9.4.bb
new file mode 100644
index 0000000000..51a854d44a
--- /dev/null
+++ b/meta/recipes-support/lz4/lz4_1.9.4.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Extremely Fast Compression algorithm"
2DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
3HOMEPAGE = "https://github.com/lz4/lz4"
4
5LICENSE = "BSD-2-Clause | GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=5cd5f851b52ec832b10eedb3f01f885a \
7 file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://LICENSE;md5=c5cc3cd6f9274b4d32988096df9c3ec3 \
9 "
10
11PE = "1"
12
13SRCREV = "5ff839680134437dbf4678f3d0c7b371d84f4964"
14
15SRC_URI = "git://github.com/lz4/lz4.git;branch=release;protocol=https \
16 file://run-ptest \
17 "
18UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
19
20S = "${WORKDIR}/git"
21
22inherit ptest
23
24CVE_STATUS[CVE-2014-4715] = "fixed-version: Fixed in r118, which is larger than the current version."
25
26EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' CFLAGS='${CFLAGS}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir} BUILD_STATIC=no"
27
28do_install() {
29 oe_runmake install
30}
31
32BBCLASSEXTEND = "native nativesdk"
33
34RDEPENDS:${PN}-ptest += "bash"
35
36do_compile_ptest() {
37 oe_runmake -C ${B}/tests/
38}
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/tests/
42 install --mode=755 ${B}/tests/frametest ${D}${PTEST_PATH}/tests/
43 sed -i "s#@PTEST_PATH@#${PTEST_PATH}#g" ${D}${PTEST_PATH}/run-ptest
44
45}
46