summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.39.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.39.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.39.bb b/meta/recipes-support/libxslt/libxslt_1.1.39.bb
new file mode 100644
index 0000000000..2cc0c84bec
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.39.bb
@@ -0,0 +1,58 @@
1SUMMARY = "GNOME XSLT library"
2DESCRIPTION = "libxslt is the XSLT C parser and toolkit developed for the Gnome project. \
3XSLT itself is a an XML language to define transformation for XML. Libxslt is based on \
4libxml2 the XML C library developed for the GNOME project. It also implements most of \
5the EXSLT set of processor-portable extensions functions and some of Saxon's evaluate \
6and expressions extensions."
7HOMEPAGE = "http://xmlsoft.org/XSLT/"
8BUGTRACKER = "https://bugzilla.gnome.org/"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
12
13SECTION = "libs"
14DEPENDS = "libxml2"
15
16SRC_URI = "https://download.gnome.org/sources/libxslt/1.1/libxslt-${PV}.tar.xz"
17
18SRC_URI[sha256sum] = "2a20ad621148339b0759c4d4e96719362dee64c9a096dbba625ba053846349f0"
19
20UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
21
22CVE_STATUS[CVE-2022-29824] = "not-applicable-config: Static linking to libxml2 is not enabled."
23
24S = "${WORKDIR}/libxslt-${PV}"
25
26BINCONFIG = "${bindir}/xslt-config"
27
28inherit autotools pkgconfig binconfig-disabled lib_package multilib_header
29
30do_configure:prepend () {
31 # We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header.
32 # This can be removed when upgrading to 1.1.34.
33 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
34
35 # The timestamps in the 1.1.28 tarball are messed up causing this file to
36 # appear out of date. Touch it so that we don't try to regenerate it.
37 touch ${S}/doc/xsltproc.1
38}
39
40EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
41# older versions of this recipe had ${PN}-utils
42RPROVIDES:${PN}-bin += "${PN}-utils"
43RCONFLICTS:${PN}-bin += "${PN}-utils"
44RREPLACES:${PN}-bin += "${PN}-utils"
45
46# This is only needed until libxml can load the relocated catalog itself
47do_install:append:class-native () {
48 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
49}
50
51do_install:append () {
52 oe_multilib_header libxslt/xsltconfig.h
53}
54
55FILES:${PN} += "${libdir}/libxslt-plugins"
56FILES:${PN}-dev += "${libdir}/xsltConf.sh"
57
58BBCLASSEXTEND = "native nativesdk"