summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libxslt/libxslt_1.1.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libxslt/libxslt_1.1.31.bb')
-rw-r--r--meta/recipes-support/libxslt/libxslt_1.1.31.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-support/libxslt/libxslt_1.1.31.bb b/meta/recipes-support/libxslt/libxslt_1.1.31.bb
new file mode 100644
index 0000000000..77b8b768eb
--- /dev/null
+++ b/meta/recipes-support/libxslt/libxslt_1.1.31.bb
@@ -0,0 +1,49 @@
1SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "ftp://xmlsoft.org/libxslt/libxslt-${PV}.tar.gz \
12 file://pkgconfig_fix.patch \
13 "
14
15SRC_URI[md5sum] = "14e9842a70fda476065f2eefcbc29af0"
16SRC_URI[sha256sum] = "db25e96b6b801144277e67c05b10560ac09dfff82ccd53a154ce86e43622f3ab"
17
18UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
19
20S = "${WORKDIR}/libxslt-${PV}"
21
22BINCONFIG = "${bindir}/xslt-config"
23
24inherit autotools pkgconfig binconfig-disabled lib_package
25
26# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
27do_configure_prepend () {
28 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
29
30 # The timestamps in the 1.1.28 tarball are messed up causing this file to
31 # appear out of date. Touch it so that we don't try to regenerate it.
32 touch ${S}/doc/xsltproc.1
33}
34
35EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
36# older versions of this recipe had ${PN}-utils
37RPROVIDES_${PN}-bin += "${PN}-utils"
38RCONFLICTS_${PN}-bin += "${PN}-utils"
39RREPLACES_${PN}-bin += "${PN}-utils"
40
41
42do_install_append_class-native () {
43 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
44}
45
46FILES_${PN} += "${libdir}/libxslt-plugins"
47FILES_${PN}-dev += "${libdir}/xsltConf.sh"
48
49BBCLASSEXTEND = "native nativesdk"