summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libunwind/libunwind_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libunwind/libunwind_1.6.2.bb')
-rw-r--r--meta/recipes-support/libunwind/libunwind_1.6.2.bb28
1 files changed, 25 insertions, 3 deletions
diff --git a/meta/recipes-support/libunwind/libunwind_1.6.2.bb b/meta/recipes-support/libunwind/libunwind_1.6.2.bb
index d67862608c..650e2c9ec4 100644
--- a/meta/recipes-support/libunwind/libunwind_1.6.2.bb
+++ b/meta/recipes-support/libunwind/libunwind_1.6.2.bb
@@ -1,4 +1,10 @@
1require libunwind.inc 1SUMMARY = "Library for obtaining the call-chain of a program"
2DESCRIPTION = "a portable and efficient C programming interface (API) to determine the call-chain of a program"
3HOMEPAGE = "http://www.nongnu.org/libunwind"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2d80c8ed4062b8339b715f90fa68cc9f"
6DEPENDS += "libatomic-ops"
7DEPENDS:append:libc-musl = " libucontext"
2 8
3SRC_URI = "http://download.savannah.nongnu.org/releases/libunwind/libunwind-${PV}.tar.gz \ 9SRC_URI = "http://download.savannah.nongnu.org/releases/libunwind/libunwind-${PV}.tar.gz \
4 file://0003-x86-Stub-out-x86_local_resume.patch \ 10 file://0003-x86-Stub-out-x86_local_resume.patch \
@@ -11,15 +17,31 @@ SRC_URI:append:libc-musl = " file://musl-header-conflict.patch"
11 17
12SRC_URI[sha256sum] = "4a6aec666991fb45d0889c44aede8ad6eb108071c3554fcdff671f9c94794976" 18SRC_URI[sha256sum] = "4a6aec666991fb45d0889c44aede8ad6eb108071c3554fcdff671f9c94794976"
13 19
20inherit autotools multilib_header
21
22COMPATIBLE_HOST:riscv32 = "null"
23
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[lzma] = "--enable-minidebuginfo,--disable-minidebuginfo,xz"
26PACKAGECONFIG[latexdocs] = "--enable-documentation, --disable-documentation, latex2man-native"
27
28EXTRA_OECONF:arm = "--enable-debug-frame"
29EXTRA_OECONF:armeb = "--enable-debug-frame"
30EXTRA_OECONF:aarch64 = "--enable-debug-frame"
31
14EXTRA_OECONF:append:libc-musl = " --disable-documentation --disable-tests --enable-static" 32EXTRA_OECONF:append:libc-musl = " --disable-documentation --disable-tests --enable-static"
15 33
16# http://errors.yoctoproject.org/Errors/Details/20487/ 34# http://errors.yoctoproject.org/Errors/Details/20487/
17ARM_INSTRUCTION_SET:armv4 = "arm" 35ARM_INSTRUCTION_SET:armv4 = "arm"
18ARM_INSTRUCTION_SET:armv5 = "arm" 36ARM_INSTRUCTION_SET:armv5 = "arm"
19 37
20COMPATIBLE_HOST:riscv32 = "null"
21
22LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" 38LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
23 39
24SECURITY_LDFLAGS:append:libc-musl = " -lssp_nonshared" 40SECURITY_LDFLAGS:append:libc-musl = " -lssp_nonshared"
25CACHED_CONFIGUREVARS:append:libc-musl = " LDFLAGS='${LDFLAGS} -lucontext'" 41CACHED_CONFIGUREVARS:append:libc-musl = " LDFLAGS='${LDFLAGS} -lucontext'"
42
43do_install:append () {
44 oe_multilib_header libunwind.h
45}
46
47BBCLASSEXTEND = "native"