summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libssh2/libssh2_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libssh2/libssh2_1.9.0.bb')
-rw-r--r--meta/recipes-support/libssh2/libssh2_1.9.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/libssh2/libssh2_1.9.0.bb b/meta/recipes-support/libssh2/libssh2_1.9.0.bb
new file mode 100644
index 0000000000..0b8ccbd217
--- /dev/null
+++ b/meta/recipes-support/libssh2/libssh2_1.9.0.bb
@@ -0,0 +1,53 @@
1SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9
10SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz \
11 file://CVE-2019-17498.patch \
12 file://0001-configure-Conditionally-undefine-backend-m4-macro.patch \
13 file://run-ptest \
14"
15
16SRC_URI_append_ptest = " file://0001-Don-t-let-host-enviroment-to-decide-if-a-test-is-bui.patch"
17
18SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927"
19SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd"
20
21inherit autotools pkgconfig ptest
22
23EXTRA_OECONF += "\
24 --with-libz \
25 --with-libz-prefix=${STAGING_LIBDIR} \
26 "
27
28# only one of openssl and gcrypt could be set
29PACKAGECONFIG ??= "openssl"
30PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl"
31PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
32
33BBCLASSEXTEND = "native nativesdk"
34
35# required for ptest on documentation
36RDEPENDS_${PN}-ptest = "man-db openssh"
37RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us"
38
39do_compile_ptest() {
40 sed -i "/\$(MAKE) \$(AM_MAKEFLAGS) check-TESTS/d" tests/Makefile
41 oe_runmake check
42}
43
44do_install_ptest() {
45 install -d ${D}${PTEST_PATH}/tests
46 install -m 0755 ${S}/test-driver ${D}${PTEST_PATH}/
47 cp -rf ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests/
48 cp -rf ${S}/tests/mansyntax.sh ${D}${PTEST_PATH}/tests/
49 cp -rf ${S}/tests/ssh2.sh ${D}${PTEST_PATH}/tests/
50 cp -rf ${S}/tests/etc ${D}${PTEST_PATH}/tests/
51 mkdir -p ${D}${PTEST_PATH}/docs
52 cp -r ${S}/docs/* ${D}${PTEST_PATH}/docs/
53}