summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libsoup/libsoup-2.4_2.40.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libsoup/libsoup-2.4_2.40.2.bb')
-rw-r--r--meta/recipes-support/libsoup/libsoup-2.4_2.40.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.40.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.40.2.bb
new file mode 100644
index 0000000000..9274f8c046
--- /dev/null
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.40.2.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "An HTTP library implementation in C"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8PR = "r0"
9
10SECTION = "x11/gnome/libs"
11
12DEPENDS = "glib-2.0 gnutls libxml2 libproxy sqlite3 libgnome-keyring"
13
14SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
15SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
16
17SRC_URI[md5sum] = "211ec6b733d4de33056b56838c88436e"
18SRC_URI[sha256sum] = "32e81220f53abb1f5bbe7d8b0717119df70667fc48e2342d82209ed1593e71dc"
19
20S = "${WORKDIR}/libsoup-${PV}"
21
22inherit autotools pkgconfig
23
24# glib-networking is needed for SSL, proxies, etc.
25RRECOMMENDS_${PN} = "glib-networking"