summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libproxy/libproxy_0.5.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libproxy/libproxy_0.5.4.bb')
-rw-r--r--meta/recipes-support/libproxy/libproxy_0.5.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/libproxy/libproxy_0.5.4.bb b/meta/recipes-support/libproxy/libproxy_0.5.4.bb
new file mode 100644
index 0000000000..b4f4c6d254
--- /dev/null
+++ b/meta/recipes-support/libproxy/libproxy_0.5.4.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Library providing automatic proxy configuration management"
2DESCRIPTION = "libproxy provides interfaces to get the proxy that will be \
3used to access network resources. It uses various plugins to get proxy \
4configuration via different mechanisms (e.g. environment variables or \
5desktop settings)."
6HOMEPAGE = "https://github.com/libproxy/libproxy"
7BUGTRACKER = "https://github.com/libproxy/libproxy/issues"
8SECTION = "libs"
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
11 file://src/libproxy/proxy.c;beginline=1;endline=20;md5=bb9a177ef1c995311070f34c5638a402 \
12 "
13
14DEPENDS = "glib-2.0"
15
16SRC_URI = "git://github.com/libproxy/libproxy;protocol=https;branch=main"
17SRCREV = "dff9a603d823dcc740ec966cd27960daa6b891b1"
18S = "${WORKDIR}/git"
19
20inherit meson pkgconfig gobject-introspection vala gi-docgen
21GIDOCGEN_MESON_OPTION = 'docs'
22
23PACKAGECONFIG ?= ""
24PACKAGECONFIG[curl] = "-Dcurl=true,-Dcurl=false,curl"
25PACKAGECONFIG[config-gnome] = "-Dconfig-gnome=true,-Dconfig-gnome=false,gsettings-desktop-schemas"
26PACKAGECONFIG[pacrunner-duktape] = "-Dpacrunner-duktape=true,-Dpacrunner-duktape=false,duktape"
27
28FILES:${PN} += "${libdir}/${BPN}/${PV}/modules"