summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.45.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.45.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.45.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.45.bb b/meta/recipes-support/libpcre/libpcre_8.45.bb
new file mode 100644
index 0000000000..46fedbae48
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.45.bb
@@ -0,0 +1,73 @@
1DESCRIPTION = "The PCRE library is a set of functions that implement regular \
2expression pattern matching using the same syntax and semantics as Perl 5. PCRE \
3has its own native API, as well as a set of wrapper functions that correspond \
4to the POSIX regular expression API."
5SUMMARY = "Perl Compatible Regular Expressions"
6HOMEPAGE = "http://www.pcre.org"
7SECTION = "devel"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=b5d5d1a69a24ea2718263f1ff85a1c58"
10SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
11 file://run-ptest \
12 file://Makefile \
13 "
14
15SRC_URI[sha256sum] = "4dae6fdcd2bb0bb6c37b5f97c33c2be954da743985369cddac3546e3218bffb8"
16
17CVE_PRODUCT = "pcre"
18
19S = "${WORKDIR}/pcre-${PV}"
20
21PROVIDES += "pcre"
22DEPENDS += "bzip2 zlib"
23
24PACKAGECONFIG ??= "pcre8 unicode-properties jit"
25
26PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
27PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
28PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
29PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
30PACKAGECONFIG[unicode-properties] = "--enable-unicode-properties,--disable-unicode-properties"
31PACKAGECONFIG[jit] = "--enable-jit=auto,--disable-jit"
32
33BINCONFIG = "${bindir}/pcre-config"
34
35inherit autotools binconfig-disabled ptest
36
37EXTRA_OECONF = "--enable-utf"
38
39PACKAGES =+ "libpcrecpp libpcreposix pcregrep pcregrep-doc pcretest pcretest-doc"
40
41SUMMARY:libpcrecpp = "${SUMMARY} - C++ wrapper functions"
42SUMMARY:libpcreposix = "${SUMMARY} - C wrapper functions based on the POSIX regex API"
43SUMMARY:pcregrep = "grep utility that uses perl 5 compatible regexes"
44SUMMARY:pcregrep-doc = "grep utility that uses perl 5 compatible regexes - docs"
45SUMMARY:pcretest = "program for testing Perl-comatible regular expressions"
46SUMMARY:pcretest-doc = "program for testing Perl-comatible regular expressions - docs"
47
48FILES:libpcrecpp = "${libdir}/libpcrecpp.so.*"
49FILES:libpcreposix = "${libdir}/libpcreposix.so.*"
50FILES:pcregrep = "${bindir}/pcregrep"
51FILES:pcregrep-doc = "${mandir}/man1/pcregrep.1"
52FILES:pcretest = "${bindir}/pcretest"
53FILES:pcretest-doc = "${mandir}/man1/pcretest.1"
54
55BBCLASSEXTEND = "native nativesdk"
56
57do_install_ptest() {
58 t=${D}${PTEST_PATH}
59 cp ${WORKDIR}/Makefile $t
60 cp -r ${S}/testdata $t
61 for i in pcre_stringpiece_unittest pcregrep pcretest; \
62 do cp ${B}/.libs/$i $t; \
63 done
64 for i in RunTest RunGrepTest test-driver; \
65 do cp ${S}/$i $t; \
66 done
67 # Skip the fr_FR locale test. If the locale fr_FR is found, it is tested.
68 # If not found, the test is skipped. The test program assumes fr_FR is non-UTF-8
69 # locale so the test fails if fr_FR is UTF-8 locale.
70 sed -i -e 's:do3=yes:do3=no:g' ${D}${PTEST_PATH}/RunTest
71}
72
73RDEPENDS:${PN}-ptest += "make"