summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre_8.30.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre_8.30.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.30.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.30.bb b/meta/recipes-support/libpcre/libpcre_8.30.bb
new file mode 100644
index 0000000000..83831e7830
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre_8.30.bb
@@ -0,0 +1,56 @@
1DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
2API, but a set of 'wrapper' functions that are based on the POSIX API \
3are also supplied in the library libpcreposix. Note that this just \
4provides a POSIX calling interface to PCRE; the regular expressions \
5themselves still follow Perl syntax and semantics. The header file for \
6the POSIX-style functions is called pcreposix.h."
7SECTION = "devel"
8PR = "r0"
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://LICENCE;md5=115e2bee152e2e23e838a29136094877"
11SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
12 file://pcre-cross.patch \
13 file://fix-pcre-name-collision.patch"
14
15SRC_URI[md5sum] = "98e8928cccc945d04279581e778fbdff"
16SRC_URI[sha256sum] = "c1113fd7db934e97ad8b3917d432e5b642e9eb9afd127eb797804937c965f4ac"
17
18S = "${WORKDIR}/pcre-${PV}"
19
20PROVIDES = "pcre"
21DEPENDS = "bzip2 zlib readline"
22
23inherit autotools binconfig
24
25PARALLEL_MAKE = ""
26
27CFLAGS_append = " -D_REENTRANT"
28CXXFLAGS_powerpc += "-lstdc++"
29EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
30
31do_compile () {
32 # stop libtool from trying to link with host libraries - fix from #33
33 # this resolve build problem on amd64 - #1015
34 if [ -e ${S}/${HOST_SYS}-libtool ] ; then
35 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
36 else
37 ln -sf ${S}/libtool ${S}/${HOST_SYS}-libtool
38 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${HOST_SYS}-libtool
39 fi
40
41 # The generation of dftables can lead to timestamp problems with ccache
42 # because the generated config.h seems newer. It is sufficient to ensure that the
43 # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
44 # only used for this).
45 oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
46}
47
48python populate_packages_prepend () {
49 pcre_libdir = d.expand('${libdir}')
50 do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.+', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
51}
52
53FILES_${PN} = "${libdir}/libpcre.so.*"
54FILES_${PN}-dev += "${bindir}/*"
55
56BBCLASSEXTEND = "native"