summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre2_10.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre2_10.31.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre2_10.31.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre2_10.31.bb b/meta/recipes-support/libpcre/libpcre2_10.31.bb
new file mode 100644
index 0000000000..a10c312e97
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre2_10.31.bb
@@ -0,0 +1,61 @@
1DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD"
11LIC_FILES_CHKSUM = "file://LICENCE;md5=f5e4bde9fd0493d0967b4dba9899590f"
12
13SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2 \
14 file://pcre-cross.patch \
15"
16
17SRC_URI[md5sum] = "e0b91c891a3c49050f7fd15de33d0ba4"
18SRC_URI[sha256sum] = "e07d538704aa65e477b6a392b32ff9fc5edf75ab9a40ddfc876186c4ff4d68ac"
19
20CVE_PRODUCT = "pcre2"
21
22S = "${WORKDIR}/pcre2-${PV}"
23
24PROVIDES += "pcre2"
25DEPENDS += "bzip2 zlib"
26
27BINCONFIG = "${bindir}/pcre2-config"
28
29inherit autotools binconfig-disabled
30
31EXTRA_OECONF = "\
32 --enable-newline-is-lf \
33 --enable-rebuild-chartables \
34 --with-link-size=2 \
35 --with-match-limit=10000000 \
36 --enable-pcre2-16 \
37 --enable-pcre2-32 \
38"
39# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
40# set CFLAGS_FOR_BUILD, required for the libpcre build.
41BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}/src"
42CFLAGS += "-D_REENTRANT"
43CXXFLAGS_append_powerpc = " -lstdc++"
44
45export CCLD_FOR_BUILD ="${BUILD_CCLD}"
46
47PACKAGES =+ "libpcre2-16 libpcre2-32 pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
48
49SUMMARY_pcre2grep = "grep utility that uses perl 5 compatible regexes"
50SUMMARY_pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
51SUMMARY_pcre2test = "program for testing Perl-comatible regular expressions"
52SUMMARY_pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
53
54FILES_libpcre2-16 = "${libdir}/libpcre2-16.so.*"
55FILES_libpcre2-32 = "${libdir}/libpcre2-32.so.*"
56FILES_pcre2grep = "${bindir}/pcre2grep"
57FILES_pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
58FILES_pcre2test = "${bindir}/pcre2test"
59FILES_pcre2test-doc = "${mandir}/man1/pcre2test.1"
60
61BBCLASSEXTEND = "native nativesdk"